/difficulty doesn't work, stuck in peaceful


#1

We were overwhelmed by monsters when we first started so my bother threw up a /difficulty peaceful and it worked. Since then, we have been unable to change it back to easy or any other difficulty. I have tried changing server.properties and nothing I can find works. The server tells us it works, but it doesn’t. I do not see any error messages. Game just stays in peaceful no matter what. I have read through old threads and have found no fixes or help, and that is a rabbit hole of a mess. Every thread has a link to another, older thread with a link to another, older thread etc.
I would love some help. We are using the latest version of 1.12.2 sponge


#2

If i remember correctly, sponge has its own difficulty settings that is on a per world bases. If you go into config/sponge you should be able to find the world properties file, open that and you should be able to change the difficulty there


#3

I am looking at the conf file now for overworld and there is no difficulty setting.

Blockquote

1.0

# If you need help with the configuration or have any questions related to Sponge,

# join us at the IRC or drop by our forums and leave a post.

# IRC: #sponge @ ir c.es per.ne t ( http s:// we bchat.e sper.n et/?channel=sponge )

# Forums: http s:// forums spongepowered.org/

sponge {
world {
# If ‘true’, this world will generate its spawn the moment its loaded.
generate-spawn-on-load=true
# If ‘true’, this world will load on startup.
load-on-startup=true
}
}


#4

I just looked myself. There is a config file somewhere as if you take a look at global.conf and search for difficulty (line 75) you can find a section on "multi-world-patches’ which changes the difficulty of just the world the command was sent from if the setting is true.

So it begs the question, did you use the /difficulty command in the world you wish or as a console? Etc?


#5

I tried changing that from false and true, also tried changing difficulty in game as well as through the console, neither works or does anything. Game stays on peaceful