[Discontinued] Polis [v2.7.0]


#629

@HassanS6000 I just updated to that version of SpongeForge and Forge. The commands were still not working… But that was because the correct command would have a prefix of /polis, hence /polis zonemobs <zone> ; /polis addzonemob <zone> <mob> ; /polis remzonemob <zone> <mob> . That was why the latest commands were not working - the command were simply wrong.

EDIT: On another note, the process works perfectly - just friendly reminder to unload the chunks to see changes.


#630

Ah I’ll be updating the update message :wink:


#631

Lovely! Thank you very much.:blush:


#632

Release v2.6.1

Tested on SpongeForge 1282

Changes:

  • Added the ability to disable mobs from spawning when in a zone (WarZone, or SafeZone) for specific reasons - player, non-player, or all .

Commands:

  • /polis addzonemob <zone> <mob> <all|non-player|player> - Adds mob as blocked in specified Zone.

Enjoy this Release! :smile:


#633

What do you mean by ‘specific reasons’? Will be testing this soon.


#634

Meaning you can block specifically just player spawning, non-player related spawning, or all spawning for each Entity.


#635

Is there a way for players to make item (x) usable to anyone who comes into the claim? On my pixelmon server someone wants to make his healer and pc usable to everyone in or out of the claim. Same way I can do it for SafeZone


#636

Not currently but I can look into it


#637

Also may just be my server but /p addzonemob SafeZone pixelmon:pixelmon all does not stop spawning… also tried non-player and player


#638

Is anyone having issues with the /polis addusable command? I am trying to add healers, PCs (pixelmon) but it doesn’t seem to work, as players still can’t use them (Opped can). It hasn’t been working since the newest update.


#639

I’ll look into the issue.


#640

Is there a certain permission node that can be used to let players use the usables that were added? It seems to be restricted to the lowest permission level only, but I have no idea as to why it isn’t working anymore.


#641

It looks like the addusable command does not work with Pixelmon items. It worked with regular minecraft items but the pixelmon ones still cannot be used. I even used /iteminfo from EssentialCmds to make sure I had the correct item ID. Are you aware of this problem?


#642

It would be nice if there is a setting, so players can only build in there claim and not in the free world.
Like towny has


#643

I’ll work on that option later today


#644

I am actually using this to get the correct ID, and this was working prior to the latest releases, I am positive. Pixelmon can be killed in the SafeZone, so it has to be something with non-entities.


#645

I have found how to make the Pixelmon items usable. There are 2 IDs for each item that can be used. If you scroll to the bottom of the list use those second IDs


#646

10/10 can confirm it works. Bizarre its the alternate block that actually had the correct ID.


#647

I dont know why its not working but i tryed it with Healer,PokeHealer,pixelmon:Healer,pixelmon:PokeHealer
idk whats wrong but it just wont work with the /p usable… after i tryed two, it worked but after i removed and addet it again. it wont… v.v


#648

So right now I’m having an issue with my SafeZone being only half protected. I have checked that the entire area is claimed but on one half players can break blocks and on the other they cannot. This happening to anyone else?