Dynmap issue

Hello everyone!

I get an issue with the dynmap mod. Indeed, when I try to enter the dynmap command, sponge says that an other plugin maybe use the same alias. In fact, it’s when I use the /dynmap reload command.
This issue prevent dynmap to accept any new configuration what I could do. It makes me angry a lot! :confused:

If someone had any idea to help me, I’ll take it with pleasure! :slight_smile:

In case of a conflict you can use a command by running /modid:command, so for your example /Dynmap:dynmap reload may work.

But you might also want to check which mods are using that alias.

Ho! really ? god to know! :slightly_smiling:
I thinks, it’s caused by a sponge plugins. But not sure.

So I’ve tried, but Dynmap said me the same error message: “Error occurred while executing command: A plugin may not register multiple commands for the same alias (‘dynmap’)!” :confused:

wait… that means dynmap tries to register its own command again, while actually executing it already?
Go home dynmap, you’re drunk! xD

1 Like

Is it dynmapforge for mc 1.8?

yes absolutely ^^

OK so I pulled Dynmap into my development environment (source code: GitHub - webbukkit/DynmapForge at 1.8.0)
(@mikeprimm fix your build.gradle! I had to add http://repo.mikeprimm.com/ manually)

It loads fine when launching (except for this message):


Typing dynmap at the console works, dynmap reload doesn’t, here’s the exception stacktrace: http://pastebin.com/WTcDyiwc

It seems that dynmap is re-registering commands again when reloading which shouldn’t be allowed because the old command still exists. (forge/vanilla doesn’t seem to care and just overwrites the old command). It’s possible using SpongeAPI to unregister commands but in forge/vanilla that is not possible.
This is a dynmap issue and should be reported to them.

okay thanks for the help. But in fact, when I used previous released of Sponge, the dynmap worked fine. It appears from builds of Sponge between 945 and 1000. I can’t say exactly the version at the time, but I could search. ^^

I posted the issue with your answer on the github issue tracker of Dynmap dev. So I’m waiting for their answers! :slightly_smiling: