Eclipse gradle plugin install broken?

When I learned about gradle I wanted to learn how to use it, however I am unable to do so because I have not been able to install it onto eclipse. (I do not want to use InteliJ Ive tried it I just don’t like it).

Attempting to install it from the market place tells me this

and using the update site linked here eclipse-integration-gradle/ at master · spring-projects/eclipse-integration-gradle · GitHub only gives me this when I go to the site for any of the links.

Any solutions?

I definitely recommend you to try IDEA instead of eclipse. The gradle/maven support is way better than in eclipse. Although its a bit hidden at “view”–>“tool windows”.

I am aware I can use gradle right off the bat in IDEA. I have it installed. I just don’t like it.

When I learned about gradle I wanted to learn how to use it, however I am unable to do so because I have not been able to install it onto eclipse.

Eclipse is not a dependency of Gradle. If you want to learn how to use Gradle then read the Gradle docs on their website. There is a TON of information. You don’t need to use an IDE, and in fact the IDE is slowing you down and causing you more problems because of the third party plugin designed to integrate Gradle with you IDE.

I would also suggest using IntelliJ Idea. But if you don’t want to, hell even Netbeans will work if you must have an IDE. Otherwise, why not just use some command line editing?

tl;dr: If you want to learn Gradle, why tie yourself down to something that is preventing you from learning Gradle?

1 Like

I have no experience with the command line is why I choose to go through an IDE. Even more so with an IDE I am familiar with. If you have a link tutorial on how to work with gradle through the command line I would be interested in that. The instructions on the gradle site do not help me one bit.

I still would like to know of any solutions to why I am unable to install this plugin to eclipse.

I always have to re-install the Gradle Plugin when I’m using a computer at my university.

I always get the same error, but the installation works. Just ignore it, accept the license agreement and it will work. I would not install the optional parts of the plugin, those are just spamming ‘Did you know?’ boxes and ‘welcome pages’ when you start eclipse

i’ve found the IntelliJ gradle integration to be as annoying as Eclipse’s random decision do build the entire project, except that it happens when you change certain things and every single time you go to debug, however this may just be android studio.

but back on-topic, i recommend you just use command line, it’s pretty easy in windows cos i have a shortcut with no start in argument and just run gradlew commands from there (obviously i’m using forge’s gradle wrapper they provide), the only commands you need to really know are the workspace setup commands (forge uses “gradlew setupDecompWorkspace” or “gradlew setupDevWorkspace” then “gradlew eclipse”) and the build command (simply “gradlew build”), obviously there are other things that you can do with gradle but as DarkArcana said just go look at their website.
TL;DR gradle is easier on command line

I have ignored it, but the option to create a gradle project does not show up in the project creation drop down like it does for maven. Am I missing something?

Problem is I have no experience with the command line so any of the user instructions and tutorials for that on the gradle site leave me not knowing what to do.

It could just be me to, I need a working example to experiment with hands on to understand something I can’t seem to learn just by reading something. If I can’t test out what I read right away then it hasn’t taught me anything in most cases.

Try File > Create Project > Other. You should see a Gradle folder.

this is all that shows up

And I tried installing it just now

What version of eclipse do you use?

Are you using the newest major eclipse version?

Also, which parts of the plugin did you install? I think the first 2 are required…

Which ‘Perspective’ are you using?

Eclipse luna,

I installed the first two like you said, I am in the Java perspective.

It looks like their update site is down. I’ve zipped up the files you need for the plugin if you want to attempt manual installation, it’s not that hard.

First download this zip file and extract the contents directly into your eclipse installation folder. Next you will need to navigate to configuration/org.eclipse.equinox.simpleconfigurator and open the file, copy the lines from that and paste them into (I guess that’s pretty self explanatory but heh).

Run eclipse and check that the plugin shows up in your installed software list (hint: press ctrl-3, begin to type “install” and click “Installation Details”. If it doesn’t show up, press ctrl-3 again and open the Error Log, see if you see any errors mentioning missing dependencies. You can also ctrl-3 and open the Plug-Ins view and look to make sure the following bundles are loaded:

If any of them are missing, check that the zip was extracted correctly and that you added all the bundles to the end of

That did the trick, thanks for your help.


Actually it errors when I try to make a project

I believe its because I am using eclipse luna (4.4), there is an entirely separate gradle plugin for that version on the market place. You wouldn’t happen to have those files would you?

Ill get the version before to see if it works with that.

The files you gave do in fact work for eclipse kepler, I guess I should use that for now until the update site is back up. If you do have the files for eclipse luna however I would much prefer to use them.

On another note, is there an eclipse plugin to have some text formatting for the build.gradle? with just the eclipse plugin files you sent it is just a simple text file.

I’m using Luna but without poring through the entire manifest it was going to be tricky to get every last bit of the installation, especially stuff that’s not in bundles.

For the syntax highlighting why don’t you just add groovy support?

No worries if its to much work, the gradle update site cant be down forever.

Thats what the build.gradle is? good to know.

Sorry I didn’t see this before. I am integrating gradle at work to replace maven
The gradle plugin for eclipse doesn’t work native on eclipse. But you need to add ats workbench first ( spring framework support ) or it comes already installed if you download sts from the spring people - sts is just a custom version of eclipse you may want to try that.

Just one more quick question, with the groovy eclipse plugin do you happen to know what out of the following I don’t need?

All we use at work is the gradle IDE plugin