Entity being removed for bounding box restrictions


#1

So I set this Groudon’s size to Ginormous and when I try to send it out it just spawns for like a second and then despawns. So yeah… idk what to do…

idk what you guys want to see exactly (I’m really new to this) but this is what it says in the console:

[11:27:45] [Server thread/WARN] [Sponge]: Entity being removed for bounding box restrictions
[11:27:45] [Server thread/WARN] [Sponge]: BB Size: 1,200 > 1,000 avg edge: 9.656
[11:27:45] [Server thread/WARN] [Sponge]: Motion: (0, 0, 0)
[11:27:46] [Server thread/WARN] [Sponge]: Calculated bounding box: box[-241.75361970886829, 70.70980193901651, -287.61755335626486 -> -232.43105939850452, 81.03236224938028, -278.2949930459011]
[11:27:46] [Server thread/WARN] [Sponge]: Entity bounding box: null
[11:27:46] [Server thread/WARN] [Sponge]: Entity: EntityPixelmon[‘Groudon’/48, l=‘world’, x=-237.09, y=70.71, z=-282.96]
[11:27:46] [Server thread/WARN] [Sponge]: Entity NBT: {EVSpeed:70s,PixelmonMovePPBase3:5b,PixelmonMovePPBase2:10b,PixelmonMovePPBase1:15b,PixelmonMovePPBase0:10b,Attributes:[{Base:256.0d,Name:“generic.maxHealth”},{Base:0.0d,Name:“generic.knockbackResistance”},{Base:0.55d,Name:“generic.movementSpeed”},{Base:0.0d,Name:“generic.armor”},{Base:0.0d,Name:“generic.armorToughness”},{Base:1.0d,Name:“forge.swimSpeed”},{Base:16.0d,Name:“generic.followRange”}],Invulnerable:0b,Gender:2b,Name:“Groudon”,IVDefence:31b,IVSpDef:31b,CaughtBall:2b,PersistenceRequired:0b,Ability:“Drought”,originalTrainer:“setic”,DoesLevel:1b,Variant:0s,PixelmonMoveID1:458s,OwnerUUID:“22d25462-507d-4b4e-9306-673e24caedac”,PixelmonMoveID0:139s,EVSpecialAttack:70s,Pos:[-237.0923395536864d,70.70980193901651d,-282.956273201083d],IVSpeed:31b,pixelmonType:0b,pixelmonOwnerUUIDMost:2509160723632704334L,EVDefence:95s,Level:70,ForgeData:{SpongeData:{CanGrief:1b,maxAir:300,Creator:{UUIDMost:2509160723632704334L,UUIDLeast:-7852475383670968916L}}},IVAttack:31b,Growth:7b,PixelmonMovePPMax1:24b,PixelmonMovePPMax2:16b,PixelmonMovePPMax3:8b,EVSpecialDefence:70s,StatsSpecialDefence:164s,PixelmonMoveID3:126s,IsInBall:0b,PixelmonMovePPMax0:16b,PixelmonMoveID2:58s,Friendship:0s,transform:0s,StatsDefence:239s,EVAttack:120s,StatsSpecialAttack:160s,IVHP:31b,AbilitySlot:0b,EVHP:85s,EggMoves:[I;],Nature:7b,pixelmonOwnerUUIDLeast:-7852475383670968916L,Motion:[0.0d,0.0d,0.0d],StatsHP:256s,UUIDLeast:-4689738788961242633L,Health:256.0f,Aggression:1b,IsFainted:0b,OnGround:0b,Dimension:0,Rotation:[-168.20837f,-2.881129f],StatsSpeed:164s,StatsAttack:282s,IsShiny:0b,PixelmonMovePP3:5b,UUIDMost:7821479264771854253L,PixelmonMovePP2:10b,PixelmonMovePP1:15b,PixelmonMovePP0:10b,Fire:0s,pixelmonID1:1350388558,pixelmonID2:16,PixelmonNumberMoves:4b,IVSpAtt:31b,EXP:0,EXPToNextLevel:18638}

please help…


#2

The config value max-bounding-box-size sets the maximum size of an entity’s bounding box before removing it. You can set it to 0 to disable this feature.
See https://docs.spongepowered.org/stable/en/server/getting-started/configuration/sponge-conf.html
(although it’s a little out-of-date in places, and is due a clean up).


#3

Thank you very much, it worked