Error when trying to start server

When trying to start my server it gives the following error, i have forge in main directory

null v1.12.2-2825-7.1.6-RC3741 for Minecraft Forge 2825
implementing null version 7.1.0-1e966facc

Oops! You attempted to run the Sponge Forge Mod directly!
This jar file is a mod for Minecraft Forge. You can run this file as a Forge
mod by installing Minecraft Forge and simply dropping the jar file into the
Forge “mods” directory. You can get Minecraft Forge from:


Once you have downloaded and installed Forge, you can load Sponge as a mod.
If you need more help, you should check out our forums:
http://forums.spongepowered.org/

Did you even read what you just posted? Please, take your time …

Don’t run SpongeForge, run Forge, and it will load SpongeForge.

I am trying to start with this button, where can i change to forge?Ekran%20Al%C4%B1nt%C4%B1s%C4%B1

This picture doesn’t help us at all and without more context we can’t really help you with your question.

Whatever start-up configuration your server setup is using is wrong, if it’s trying to launch SpongeForge on it’s own. If you don’t know how to change that, you need to contact your hosting company for help.
You just need to start a Forge server, with SpongeForge inside the mods folder.
For example, spongeforge-1.12.2-2838-7.3.0.jar needs Minecraft Forge version 2838 (or newer).

1 Like