Exception trying to load level_sponge.dat, file corruption maybe?

Hi, I am new here. I hope I am posting it properly.

So I been playing with my friends and the server has been running well for a month but one night when I tried to open the server again, it shows me this.

Solutions I tried.

  1. Deleted the level_sponge.dat
  2. Replaced level_sponge.dat with level_sponge.dat_old
  3. Tried Windows Restore Point
  4. Replaced sponge.dat files with backup files as well.

Any help would be appreciated. Thanks!

What that’s not good at is telling you which world that’s affecting. There are multiple level_sponge.dat files, one for each world. It’s likely that your nether and/or end ones were corrupted, go into their directories and do the same as you’ve done with the overworld one.

I did that as well. I have World, DIM1, and DIM-1. I deleted their 3 Sponge Date and tried, still same error. Replaced the sponge data as well, still same error. For some reason its give the same error of corrupted sponge data when there is no sponge data.

Can you upload the entire debug.log to pastebin or gist and share that?

It might show more details

This is the crash report when Sponge dat and sponge old is removed from all 3. And Pastebin doesn’t take a big file like debug and I got no idea of how to use gist. I am sorry.

Is this correct?

[22:47:11] [Server thread/ERROR] [net.minecraft.world.storage.SaveFormatOld]: Exception reading .\world\ultra\level.dat

It looks like the ‘Ultra’ world is the one having issues. I see exceptions for both the level_sponge.dat, but also the regular level.dat which is a larger issue.

so if I replaced ultra world’s level with a backup? Would it work?

Yes. Depending on what you have done since the backup was created some things about the world maybe out of line (such as if you have created/edited the world border then it will have the older settings)

Make sure you also replace the sponge version too at the same time to keep those two in sync.

Well for now I just removed the full folder and pulled a very old backup to work on for now since even my latest backup isnt able to work on it. But thanks though for the help.