Forge server crashing with SpongeForge - class loaded prematurely

I have been running a FTB Presents Hermitpack server on CubedHost for about 6 months. Recently, I have been dealing with server-crippling lag. I used Spigot in the past when I ran a server from home, but I have chosen to try Sponge based on many hours of Forge vs. Spigot (and the *kit family and drama) vs. Sponge research.

As soon as I upload Sponge jar into my mods folder and restart the server, it crashes. I’ve verified the Applied Energistics 2 mod is the latest build for Sponge (rv4-alpha-11). And, the server starts without any issues when I remove the Sponge jar.

ftb-hermit-pack      1.7.0
Minecraft            1.10.2
jdk                  1.8.0_131
Sponge   spongeforge-1.10.2-2254-5.2.0-BETA-2272

Server outputs can be found at :

Server latest log:
Console output:

Any help will be greatly appreciated!

Some coremod is loading before sponge, I’m not sure which. Have you tried using the Foamfix-Lawful version (ie the one without the mixin)?

Thank you @Inscrutable for the response.

I tried Foamfix-0.6.2-Anarchy and Foamfix-0.6.2-Lawful and the same thing happened.

I decided to remove AE2 just to confirm it wasn’t causing any problems given the recent issues and the server started up.

First, I will try the SpongeBootstrap solution presented at If that doesn’t work, I will begin looking at AE2 and see what I can figure out.