Forge server won't even start

Hey! I’m quite new with sponge, and when I found it my soul found hope once again. I’ve been creating servers for my friends for quite some time, and starting up the server with forge without sponge seemed to work, yet every time I tried with it, not even the console command would show up. I’ve noticed that it’s usually a compatibility issue yet I don’t know if this is my case, any help would be appreciated.

Crash reports come out blank, so only logs provide any info


[18:40:40] [Server thread/INFO]: Starting minecraft server version 1.12.2
[18:40:40] [Server thread/WARN]: To start the server with more ram, launch it as “java -Xmx1024M -Xms1024M -jar minecraft_server.jar”
[18:40:40] [Server console handler/ERROR]: Exception handling console input Controlador no válido
at Method) ~[?:1.8.0_121]
at Source) ~[?:1.8.0_121]
at Source) ~[?:1.8.0_121]
at Source) ~[?:1.8.0_121]
at sun.nio.cs.StreamDecoder.readBytes(Unknown Source) ~[?:1.8.0_121]
at sun.nio.cs.StreamDecoder.implRead(Unknown Source) ~[?:1.8.0_121]
at Source) ~[?:1.8.0_121]
at Source) ~[?:1.8.0_121]
at Source) ~[?:1.8.0_121]
at Source) ~[?:1.8.0_121]
at Source) ~[?:1.8.0_121]
at net.minecraft.server.dedicated.DedicatedServer$ [nz$2.class:?]
[18:40:59] [Server thread/INFO]: Loading properties
[18:40:59] [Server thread/INFO]: Default game type: SURVIVAL
[18:40:59] [Server thread/INFO]: Generating keypair
[18:40:59] [Server thread/INFO]: Starting Minecraft server on *:25565
[18:40:59] [Server thread/INFO]: Using default channel type
[18:41:02] [Server thread/INFO]: Preparing level “world”
[18:41:06] [Server thread/INFO]: Loaded 488 advancements
[18:41:06] [Server thread/INFO]: Loaded 6 advancement trees
[18:41:08] [Server thread/INFO]: Preparing start region for level 0 (world)
[18:41:10] [Server thread/INFO]: Preparing spawn area: 0%
[18:41:11] [Server thread/INFO]: Preparing spawn area: 9%
[18:41:12] [Server thread/INFO]: Preparing spawn area: 25%
[18:41:13] [Server thread/INFO]: Preparing spawn area: 38%
[18:41:14] [Server thread/INFO]: Preparing spawn area: 46%
[18:41:16] [Server thread/INFO]: Preparing spawn area: 52%
[18:41:17] [Server thread/INFO]: Preparing spawn area: 57%
[18:41:18] [Server thread/INFO]: Preparing spawn area: 60%
[18:41:19] [Server thread/INFO]: Preparing spawn area: 62%
[18:41:20] [Server thread/INFO]: Preparing spawn area: 63%
[18:41:21] [Server thread/INFO]: Preparing spawn area: 64%
[18:41:22] [Server thread/INFO]: Preparing spawn area: 65%
[18:41:24] [Server thread/INFO]: Preparing spawn area: 65%
[18:41:26] [Server thread/INFO]: Preparing spawn area: 65%
[18:41:35] [Server thread/INFO]: Preparing spawn area: 65%
[18:41:37] [Server thread/ERROR]: Encountered an unexpected exception
java.lang.OutOfMemoryError: Java heap space
at net.minecraft.nbt.NBTTagByteArray.func_152446_a(SourceFile:52) ~[fw.class:?]
at net.minecraft.nbt.NBTTagCompound.func_152449_a( ~[fy.class:?]
at net.minecraft.nbt.NBTTagCompound.func_152446_a( ~[fy.class:?]
at net.minecraft.nbt.NBTTagList.func_152446_a( ~[ge.class:?]
at net.minecraft.nbt.NBTTagCompound.func_152449_a( ~[fy.class:?]
at net.minecraft.nbt.NBTTagCompound.func_152446_a( ~[fy.class:?]
at net.minecraft.nbt.NBTTagCompound.func_152449_a( ~[fy.class:?]
at net.minecraft.nbt.NBTTagCompound.func_152446_a( ~[fy.class:?]
at net.minecraft.nbt.CompressedStreamTools.func_152455_a( ~[gi.class:?]
at net.minecraft.nbt.CompressedStreamTools.func_152456_a( ~[gi.class:?]
at net.minecraft.nbt.CompressedStreamTools.func_74794_a( ~[gi.class:?]
at ~[aye.class:?]
at ~[ChunkIOProvider.class:?]
at net.minecraftforge.common.chunkio.ChunkIOExecutor.syncChunkLoad( ~[ChunkIOExecutor.class:?]
at ~[on.class:?]
at ~[on.class:?]
at$onProvideChunkHead$zme000( ~[on.class:?]
at ~[on.class:?]
at net.minecraft.server.MinecraftServer.prepareSpawnArea( ~[MinecraftServer.class:?]
at ~[WorldManager.class:1.12.2-2611-7.1.0-BETA-2990]
at ~[WorldManager.class:1.12.2-2611-7.1.0-BETA-2990]
at net.minecraft.server.MinecraftServer.func_71247_a( ~[MinecraftServer.class:?]
at net.minecraft.server.dedicated.DedicatedServer.func_71197_b( ~[nz.class:?]
at [MinecraftServer.class:?]
at Source) [?:1.8.0_121]

Looks like a simple out of memory error. Most modded servers will require at least 2gb allocated, you only have one (I allocate 8gb for 80 mods, 20 players).

1 Like

but how much memory does it require? right now the only mod in my folder is sponge, as I’m trying to get it running before adding mods. Also, I’ve been trying to give it more memory yet this pops out.

Out of memory?

C:\Users\usuario\Desktop\Juegos\DND MC>java -Xms2G -Xmx2G -jar minecraft_server.jar nogui
A problem occurred running the Server
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at net.minecraftforge.fml.relauncher.ServerLaunchWrapper.main(
Caused by: java.lang.NoClassDefFoundError: org/apache/logging/log4j/Level
at net.minecraft.launchwrapper.Launch.launch(
at net.minecraft.launchwrapper.Launch.main(
… 6 more
Caused by: java.lang.ClassNotFoundException: org.apache.logging.log4j.Level
at Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
at java.lang.ClassLoader.loadClass(Unknown Source)
… 8 more

C:\Users\usuario\Desktop\Juegos\DND MC>pause
Presione una tecla para continuar . . .

Also, I’ve been able to start the server without sponge and other mods, it’s when sponge comes into contact that it won’t even try to start.

You’re supposed to be running the Forge jar, not the Minecraft jar. And if 2G isn’t enough, try 3 or maybe 4.

I just renamed the forge.jar file to minecraft.jar it seemed easier than doing it the other way round, i’ve got 8g ram, so I think using half of it on the server, is kind of not an option.

If you have 8GB of ram, and are running on Linux, you could probably safely allocate 7GB to the Minecraft server.

-edit- just realized your running on Windows. In that case you can’t allocate 7GB. In all seriousness tho, if you want more than like two players to be able to connect with sponge, you will probably need more RAM (I may be full of ****, I haven’t run low RAM servers with sponge in a while).


Try running the server with just Forge first, before adding SpongeForge. If that won’t work, it’s not Sponge that’s the problem. You shouldn’t need heaps of RAM either, unless you have a huge load of Forge mods. I’ve been able to run a modded (30+ mods) SpongeForge server on 3GB, with half a dozen players.

That’s the great part! I shouldn’t need that much RAM, it’s only me and two of my friends, for the most part.

Forge on its own runs like a charm, it’s when I add SpongeForge. For testing purposes I always try to run the server with just SpongeForge, but it just doesn’t want to start. I’m not even sure what to show you, cause no crash logs are recorded, it just stops.

Am I missing a core mod perhaps? Does SpongeForge need anything else to work?
edit: (didn’t feel like replying once again) I’ve even tried with older spongeforge files, to see if that would solve anything, sadly it did not…

All SpongeForge needs is the right version of Forge (or newer) (oh, and Java 8 v 20+). Is some of your system memory locked up somehow? If all you get are out-of-memory errors then something else is afoot. So far we don’t even know what version of Sponge you’re using, or many of the other system details that might help isolate the problem.
You could try deleting the sponge config folder, if you modified that in any way, but that’s probably not what’s causing this.

I’ve been using 2611 as stated with the download files. I started out with the latest recommended file yet I’ve downgraded to “spongeforge-1.12.2-2611-7.1.0-BETA-2990” I’ll try deleting the config folder, but i haven’t touched it in any way, as I’m new with sponge, I wouldn’t even know where to start.

OK, Just so you know, spongeforge-1.12.2-2611-7.1.0-BETA-2990 is the latest non-bleeding build, and also the current recommended build. If you’ve been using the API-8 builds, be aware that they are highly unstable and only really useful for a testing environment at present.

Don’t worry, I only got the recommended builds, I’m usually cautious when it comes to new software.

What @Inscrutable said is that is 2661-2990 is the latest recommended. So if you’ve ‘downgraded’ to that build then that means you started on an unstable build.


@TBigDonut if you send me a list of your mods/plugins, and the versions, I’ll set up a test server and see if I can’t recreate the issue. Depending on how many mods/plugins you have, it could also be that sponge is pushing the RAM just over the limit.

Java out of memory exceptions are pretty unusual, and typically aren’t really caused by the programs typical usage. Usually something unusual is going on.

If things keep failing, you/we could always try to use a memory profiler, and see exactly what is taking up so much space.

1 Like

Those are the only files I downloaded, I started out with build 2990, and downgraded to 2979

As for the mods it’s only spongeforge, and no other plugins, otherwise, using the forge server without it works just fine, and for that I’m only using CustomNPC and VariedCommodities. Yet as I said, when trying to run the server for the first time, it’s only SpongeForge on my list.