FTB Revelation 2.6.0: Possible Server Memory Leak?


#1

Hello!

I posted over at the FTB forums and someone suggested I inquire over here-- let me if you need more info!

Server Info
RAM: 5gb
FTB Revelation 2.6.0
Minecraft 1.12.2
Forge 2768
SpongeForge 1.12.2-2768-7.1.4

Other plugins:
MagiBridge
MBDiscordLink
RandomPatches
GriefPrevention
LuckPerms
Nucleus

I’m currently running into what I believe to be a memory leak with my FTB Revelation server. About every three hours, my server host automatically restarts my server due to it exceeding 5.5gb of ram usage.

Here’s a graph of the memory and CPU usage:

(on the 5th of February, I upgraded the server from 4gb to 5gb, hence the increase)

I’ve been trying to diagnose as best as I can, but Minecraft servers are not my area of expertise by any means. I’ve also been trying to gather info from timings and heap dumps, but timing reports seem to indicate no issues (to the untrained eye, maybe) and I can’t quite figure out how to interpret heap dumps-- help in this area would be greatly appreciated.

I’ve removed a few plugins (Prism, spark) entirely and temporarily disabled MagiBridge and MBDiscordLink to attempt to resolve the issue but haven’t had luck. I’ve run a new world and it seemed to perform noticeably better, but I’ve yet to test a new world over an extended period of time to be totally sure.

These issues have been happening prior to any major “advancements” in the modpack, so to speak (use of higher end technology mods, etc). When there are no players on the server, the ram climb slows down but is still present. This can be seen in the overnight areas of this graph:

In addition to this, there’s definitely a slower RAM climb when certain people (and therefore, presumably their chunks?) are online.

I would include a log but I’m not sure which I’d attach (or if it would even help) as it’s not exactly a crash, but a forced restart. I’m open to any and all help and suggestions. I just don’t want to have to start a new world without asking people wiser than me if they have any potential solutions :slight_smile:

Worth mentioning: I’ve tried to use Eclipse Memory Analyzer with heap dumps generated form Sponge, but I don’t think I’m doing it right hahaha. If anyone has a guide (or would be willing to look at a heap dump) let me know!

I’ve also tried implementing this fix but did not seem to have much luck:

Thank you for your time!


#2

Out of curiosity, what speed CPU are you using, and how many cores/threads…?


#3

for the entire machine that this server is hosted on this is the info my host (NFOServers) provides:

Your server is currently being hosted on a Dual Intel Xeon E5-2697Av4 (Broadwell 2.6ghz) node with 32 total processor cores and 192 gigabytes of RAM. Its OS is Linux.


#4

I never know which errors are ignorable and which aren’t so I figured I’d post a link to a full log from server start to automatic restart due to high RAM, if it helps. In this case, it looks like the server backup pushed it over the edge (though the RAM had been climbing up until this point).
Log: https://www.dropbox.com/s/fuleal4v4u68qqg/2019-02-15-2.log?dl=0
Usage (this log relates to the last big dip on this graph):
https://i.imgur.com/E8jAHpJ.png


#5

So I wanted to bump with a heap dump taken from sponge, but after 13 minutes of the server being up it produced a heap dump 1.7gb in size. Is this normal? If so, I’m a bit out of the loop on file sharing sites these days; does anyone have any recommendations for where I could host a file so large?

I feel like someone who knows what they’re looking for in a heap dump would be an amazing help :slight_smile:

Otherwise, if someone can point me in the right direction with interpreting a heap dump it would be greatly appreciated!


#6

Hi again!

Since I last posted, I’ve tried a few more things to no avail:

  • Generating a new world with the current modpack (with no additional mods and with added mods [SpongeForge, Nucleus, LuckPerms, GriefPrevention, MagiBridge]). Resulted in the same issue. Here’s the usage:
    https://i.imgur.com/mEYbWXj.png

The first three peaks are a new world on a new install of FTB Revelation 2.6.0 with no other mods. The last peak is with the additional mods listed above.

Since then, I’ve upgraded the server to FTB Revelation 2.7.0 but the climbs are about the same. Would it be possible that this is somehow a server host issue? I’ve used the same host since 2013 and they’ve been excellent otherwise, but it is a shared PC and I feel as though I’ve exhausted other options.

This drifted away from being a Sponge issue a while ago, so feel free to relocate this thread as is appropriate. Still, if anyone has even the faintest suggestion let me know!