FTB Unlimited reloaded Not working, Someone Experienced plz!


#1

Few things I should mention before I get into the nitty-gritty of it all.
I’m running a dedicated ssh server from soyoustart in Canada, it is a Ubuntu 19.04 server OS, 32GB of ram, and a i7 8 core CPU.

I’m trying to run Spongeforge on this sever correct? well there’s one HUGE problem, the FTB server is using forge version 1.12.2-14.23.5.2836, and spongeforge needs version 1.12.2-14.23.5.2838. Ive tried just installing SF(spongeforge) and sadly, it didn’t work not that I thought it would. Then I renamed the version of forge on my server to match the version of forge that SF needs to run and then changed the script in the settings.sh file to match the same version so that I could get past the forge check, Also didn’t work. Then I installed the version of forge that SF wanted on the server, deleted the other version that came with FTB, changed the Settings.sh file in FTB to match the name of the forge I had again and… SF error again… but it says the same error every single time “your running version 1.12.2-14.23.5.2838 you need version 1.12.2-14.23.5.2838”.
After this I had nothing else I could think of doing, Ive tried contacting FTB regarding this issue and they wont answer me, Ive gone to multiple customer service places for minecraft servers and no one can help me. So i looked up Minecraft server Customer support and here I am. Good luck because this seems like a huge challenge to me!


#2

The error message of "your running version 1.12.2-14.23.5.2838 you need version 1.12.2-14.23.5.2838” is normal, even for servers that match the version (not sure what causes that message to send). The error will not stop your server from launching, nor will it cause a error if the versions match.

Just to note the version sponge requires is the minimum version, you can have a newer version of forge compared to your sponge and expect the same result (unless there is a breakage in forge).

What is happening for you to think there is a error? Such as is the server not starting? Can players not connect?