GAME CRASH: An unexpected issue occured

When I try to launch minecraft with this new launcher and spongeforge isntalled it says “An unexpected issue occured and the game has crashed”
Sponfeforge version - spongeforge-1.10.2-2221-5.1.0-BETA-2135
EDIT: Found a crashlog.

1 Like

Neat! Could we get the server log instead, then?

Found a crashlog.

Here is the problem: you are trying to run spongeforge-1.10.2-2202-5.1.0-BETA-2078.jar using forge-1.10.2- You need to update Forge. The minimum Forge version is part of the SpongeForge filename (i.e. 2202).

EDIT: Which is odd, as you say in the OP that you used spongeforge-1.10.2-2221-5.1.0-BETA-2135. It might be worth double checking that …

Nothing odd, I just switched my SpongeForge :smiley:
Using forge 2202 didn’t fix the problem.
EDIT: It really creates no crashlog, this one was created because I use wrong version of forge

Can anyone test latest spongeforge on 1.10.2 with this new laucher? So I can know, if thats my problem or sponge’s.

I am having exactly the same problem with the new launcher.

Using SpongeForge 1.10.2 for Forge 2221, and Forge version 2221.

Mojang says that the new interface shouldn’t have changed anything or created any problems, but as soon as it got updated, I could no longer launch minecraft with SpongeForge in my mods folder.

Just like @ziment stated, it creates no crashlog, only saying “An unexpected issue occurred”.

Nothing fancy, but this is what the message looks like in the new launcher.

1 Like

I’ll take a look into this.


This is an issue in ReplayMod. However, it’s a very simple proble, so it should hopefully be fixed very soon.

I know about this issue, but removing replay mod didn’t fix the problem.

Ah, yeah I’m afraid that isn’t the issue for me either. :frowning:
Thanks for your work on this problem, but I don’t actually have ReplayMod, nor have I ever have.

That’s incredibly odd - I saw exactly the same crashlog as you did when I tried to run ReplayMod and Sponge. Can you and @Nys pastebin your new stacktraces/crashlogs? Additionally, please upload your fml-client-latest.log.

Sure thing, I’ll try to give you as much as I can.

The launcher doesn’t generate a crashlog from this error, which is very odd, but I do have the latest log that the launcher makes from attempting to start it.

Here it is. The mods that I am running in this log are JourneyMap, MorePlayerModels, Optifine, along with SpongeForge.

I’m sorry that I don’t have anything besides this, but its the only thing that the error will generate.

I wasn’t able to reproduce that crash with those mods. Can you list the exact versions of every mod you have installed? Additionally, see if you can get the crash to happen with just SpongeForge and one of the mods.

Also, it looks like you’re running Java 1.8.0_25, which is very outdated. Make sure you update to the latest version of Java 8, as there are bugs in older versions which can cause problems with Sponge.

1 Like

I’m having the same problem in new launcher. Using Forge, and only SpongeForge 1.10.2-2221-5.1.0-BETA-2143 mod.
New minecraft launcher downloading java to the “.\Minecraft\runtime\jre-x64\1.8.0_25”, but you can set your oun path to Java in preferences.
There is no crush logs, only latest.log.

1 Like

Ahh, I went and updated Java before posting, but as @Xinarivar mentioned, the new launcher continues to make a new 1.8.0_25 version every time I try to update (Which I totally didn’t realize it was doing, my bad). Instead, the path has been redirected directly to the Java folder with v. 1.8.0_121, which I believe is the latest version possible.

Also sure thing! The mods launched in that report are:
JourneyMap version 1.10.2-5.4.4
MorePlayerModels version - 1.10.2(11nov16)
Optifine version - 1.10.2_HD_U_D6
SpongeForge version 1.10.2-2221-5.1.0-BETA-2136

It does crash with just SpongeForge in the mods folder as well. I’ve tried several of the different versions to see if that was the problem, but it refuses to launch regardless of version it appears.

And here is just SpongeForge along with Optifine.

Also I have the similar problem with MC 1.11.2:
Forge 1.11.2
SpongeForge 1.11.2-2227-6.0.0-BETA-2157
And there is a crash report.

1 Like

The problem was solved in MC 1.11.2 with:
Forge 1.11.2
SpongeForge 1.11.2-2227-6.0.0-BETA-2232
I’m not testing MC 1.10
Also set Java x64 v1.8.0_121.

Thanks a lot! I’ll try updating Forge, then.