⚙ UltimateCore - The Best Essentials Plugin! (API 7, MC 1.12)


#82

I think it’s a api 6 issue, with api 5.1 and 5.2 works fine


#83

Hello, I recently updated to the Alpha 3.0.7.
Now when I or players do /home I get console errors and in game error.

If I have a player that has never set any homes, they can create one and teleport to it no problem.
Also any group chat formatting I have set no longer works.

I am afraid at this point I have no console data to give you as I quickly rolled back the version and my log files do not seem to have captured the exceptions.

I am writing this with the hope you are perhaps aware already of any such issues and can offer advice / possible fixes.
I am running the direwolf20 1.10 modpack.

Thanks


#84

It would really help if you could send me the error.
I did do some fixes to the /home command which are not in an official release yet, could you try running this build:
https://www.mediafire.com/?9q11usdycfh8afa
(PLEASE CREATE BACKUPS!)

If this does not fix your issue, please come to the discord so I can help you better.


#85

Thanks for the quick reply

Please find the pastbin below
http://pastebin.com/TJCPnQAR

Please note there are 3 sets on console output in there
1: Latest you sent me (/home)
2: Latest Alpha release 3.0.7 (during startup)
3: Latest Alpha release 3.0.7 (/home)

I did not notice any console errors on the latest you sent me.
I have had to come away from your plugin for now but it has served me well so thankyou.
I will do my best to help you with testing so if you want me to do anything else then please shout up.

Thanks
macman


#86

It looks like your language file somehow corrupted, could you try to reset your language file, and then run the latest file I sent you?


#87

My server has a few players on it right now, I have highlighted this message in my email and as soon as the server goes quite I will do this.

Nice to see your on the ball with this.


#88

If you are keen to test to confirm your theory I can always send you the language file.

You can email me at macman@minecraftiplist.com and I will send you by return.

I tried to copy it in here but only images are allowed


#89

You can actually use pastebin.com to send me your language file.
If you want faster help, you could come to my discord (link in main thread)


#90

Here you go, I am in no real rush right now but here is the file.
I will do the test you suggested when my server quitens down.

http://pastebin.com/W4WS1Xhy


#91

I tested the language file, but it seems to work fine.
Could you send one of the player’s user files so I can examine these?


#92

This one is mine and i was generating the exception when I ran /home

http://pastebin.com/nJhTBZUq


#93

One thing to note @Bammerbom is that this direwolf20 1.10 modpack has FTButilities installed and at the time of doing these tests I had not disabled its own internal /home command.

I since have but am still unable to test for you at this time to see if that was the problem

Im sorry this has just come to mind


#94

As long as it is the UltimateCore /home command which is executed, which looking at the error it is, this shouldn’t matter.
Your player file looks fine too.

I will take a look at this issue later today or tomorrow.


#95

A new version has been released for UltimateCore, it is available for download here.


This is an alpha build and not ready for production server use.
Documentation: https://github.com/Bammerbom/UltimateCore/blob/master/docs/home.md

! All warps will be removed after installing this release

  • Added a lot of documentation for UltimateCore (see https://github.com/Bammerbom/UltimateCore/blob/master/docs/home.md)

  • Added /uc setupperms (see documentation)

  • Added /invsee (does not work with 1.10)

  • Fixed homes and warps breaking when deleting the worlds they are in

  • Updated uc hub

  • Fixed SpongeVanilla compatibility

  • Fixed certain permissions missing from the docs

  • The default module is now called ‘core’

  • Fixed default tablist footer


#96

How does the /world import command work? Any time I try and use it it just creates a new world rather than importing.


#97

Why not fusion with Nucleus?

It works like a charm and as far as I can see it is the most used essentials plugin for Sponge.

What I really like much more on UltimateCore are the modules.
This way is much more flexible and clearer.


#98

Nucleus has modules too tho.

I started this as an alternative to Nucleus, and the plugins can be used together without any problem. Just disable the modules in both plugins which you don’t need.
This plugin is more aimed towards bukkit users (its a port) with easy to use commands without way too many weird options, but while still staying very configurable.
If Nucleus wants to fuse, sure. But I don’t really see a reason to do so.


#99

Could you give me an example how to create a hover event for automessages that opens a url?


#100

Just use the normal sponge/minecraft text format.
Take a look around the web, for example at


#101

A new version has been released for UltimateCore, it is available for download here.


This is an alpha build and not ready for production server use.
Documentation: https://github.com/Bammerbom/UltimateCore/blob/master/docs/home.md

  • Added max level for /enchant
  • Fixed the /tp command without an Y coordinate
  • Fixed /world import case sensivity
  • Fixed /world command in singleplayer
  • Fixed issues with 1.10 and chatting
  • Fixed scope of chat formatter
  • Fixed some /afk logic