Holograms - Easily create floating texts!


#142

As the old config can not be read with the newer sponge builds there is no automatic way to delete them. However you could try something like /kill @e[type=armor_stand]. Please be careful, make a backup before you execute that command. It kills all armorstands in the current world you are in.

Edit: Or /kill @e[type=ArmorStand], depends on your minecraft version.


#143

It seems as though all of my holograms disappeared after a restart. They are still in the configs but they are not visible on the map. I have tried reloading the plugin and that did not work either. I am on version 2.0 and I am using sponge: spongeforge-1.10.2-2171-5.1.0-BETA-1976.jar


#144

I can’t reproduce your described behavior with a fresh setup of your mentioned version. Could you please also try it without any other mods/plugins?


#145

Sure, I will set up a new test server tonight and get back to you.


#146

So it works on a fresh server, but I’m not sure what would be conflicting with it on my main server. It wipes ALL the holograms after every restart.


#147

Please send a list if all your plugins/mods and I can try to guess which one might cause it. But that’s very vague. Of course it is better when you start with a fresh server and then add one mod/plugin at a time and test if the holograms dissapear.

Edit: Do you see armorstand in spectator mode? Maybe only the text dissapears.


#148

Using Spectator mode I still can’t see them, here is a list of plugins I am using:

EMPSponge
GriefPrevention (I think it may be this, but I can’t think of what flag would be stopping armorstands. I tried to allow the spawning of armorstands entities and reloaded the holograms but still nothing.)
LuckPerms
Nucleus
EasyScoreboards
WorldEdit


#149

I can’t think of a plugin that would do that but grief prevention seems to be the most likely one.
You have to create the hologram everytime it is gone because the armorstand is simply an entity that is saved with the world. The armorstands are not spawned everytime when the plugin reloads, they only get the text updated if they can still be found.

Start with a fresh server:

  1. Create hologram
  2. Restart server
  3. Check if hologram still there
  4. Stop server
  5. Add one plugin/mod
  6. Start server
  7. Go to 1. until all plugins are added

#150

Okie, I finally got it fixed. I had overlooked a flag that was blocking it from spawning, but it’s all good now. Thank you so much for your help!


#151

I seem to be getting this error whenever I try to make a hologram of any sort. Any Help?

 [Sponge]: Error occurred while executing command 'holograms create Welcome to Serious Servers' for source EntityPlayerMP['curscascis'/4884, l='world', x=29511.64, y=80.26, z=30092.14]: org.spongepowered.api.world.World.createEntity(Lorg/spongepowered/api/entity/EntityType;Lcom/flowpowered/math/vector/Vector3d;)Ljava/util/Optional;
java.lang.NoSuchMethodError: org.spongepowered.api.world.World.createEntity(Lorg/spongepowered/api/entity/EntityType;Lcom/flowpowered/math/vector/Vector3d;)Ljava/util/Optional;
        at de.randombyte.holograms.Hologram$Companion.spawn(Hologram.kt:24) ~[Hologram$Companion.class:?]
        at de.randombyte.holograms.commands.SpawnTextHologramCommand.executedWithPermission(SpawnTextHologramCommand.kt:16) ~[SpawnTextHologramCommand.class:?]
        at de.randombyte.holograms.commands.PermissionNeededCommandExecutor.executedByPlayer(PermissionNeededCommandExecutor.kt:12) ~[PermissionNeededCommandExecutor.class:?]
        at de.randombyte.holograms.commands.PlayerCommandExecutor.execute(PlayerCommandExecutor.kt:17) ~[PlayerCommandExecutor.class:?]
        at org.spongepowered.api.command.args.ChildCommandElementExecutor.execute(ChildCommandElementExecutor.java:179) ~[ChildCommandElementExecutor.class:1.10.2-2171-5.1.0-BETA-2005]
        at org.spongepowered.api.command.spec.CommandSpec.process(CommandSpec.java:351) ~[CommandSpec.class:1.10.2-2171-5.1.0-BETA-2005]
        at org.spongepowered.api.command.dispatcher.SimpleDispatcher.process(SimpleDispatcher.java:333) ~[SimpleDispatcher.class:1.10.2-2171-5.1.0-BETA-2005]
        at org.spongepowered.common.command.SpongeCommandManager.process(SpongeCommandManager.java:291) [SpongeCommandManager.class:1.10.2-2171-5.1.0-BETA-2005]
        at net.minecraft.command.ServerCommandManager.func_71556_a(SourceFile:83) [bd.class:?]
        at net.minecraft.network.NetHandlerPlayServer.func_147361_d(NetHandlerPlayServer.java:913) [me.class:?]
        at net.minecraft.network.NetHandlerPlayServer.func_147354_a(NetHandlerPlayServer.java:892) [me.class:?]
        at net.minecraft.network.play.client.CPacketChatMessage.func_148833_a(SourceFile:37) [im.class:?]
        at net.minecraft.network.play.client.CPacketChatMessage.func_148833_a(SourceFile:9) [im.class:?]
        at org.spongepowered.common.network.PacketUtil.onProcessPacket(PacketUtil.java:136) [PacketUtil.class:1.10.2-2171-5.1.0-BETA-2005]
        at net.minecraft.network.PacketThreadUtil$1.redirect$onProcessPacket$zjd000(SourceFile:39) [fl$1.class:?]
        at net.minecraft.network.PacketThreadUtil$1.run(SourceFile:13) [fl$1.class:?]
        at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511) [?:1.8.0_45-internal]
        at java.util.concurrent.FutureTask.run(FutureTask.java:266) [?:1.8.0_45-internal]
        at net.minecraft.util.Util.func_181617_a(SourceFile:45) [h.class:?]
        at net.minecraft.server.MinecraftServer.func_71190_q(MinecraftServer.java:668) [MinecraftServer.class:?]
        at net.minecraft.server.dedicated.DedicatedServer.func_71190_q(DedicatedServer.java:387) [ld.class:?]
        at net.minecraft.server.MinecraftServer.func_71217_p(MinecraftServer.java:613) [MinecraftServer.class:?]
        at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:471) [MinecraftServer.class:?]
        at java.lang.Thread.run(Thread.java:745) [?:1.8.0_45-internal]

#152

Please use version 2.0 for api 5.1.0.


#153

Thanks I realized I downloaded from the wrong place.


#154

@RandomByte So I manually removed a multiline hologram and it’s still in-game. What MC command to I do to remove the nearest entity or whatever I have to do?


#155

Execute /holograms force-delete, as it says in the first post. It removes every ArmorStand in a radius of 2 blocks.


#156

Alright thanks, somehow I completely overlooked that.


#157

Hello,I like this plugin very much.I want to share this plugin in MCBBS.Can you agree with me?
www.mcbbs.net :grinning:


#158

Yes


#159

OK,Thanks~:blush:
http://www.mcbbs.net/thread-660959-1-1.html


#160

What if someone has an issue with my plugin? The best thing would be that they report it either here or on GitHub. And does the post in your forum get updated when I change it here?
Note: the screenshot you posted is not reproducible with this plugin, it’s like false advertisement.
Is there a link to this forum? That would be great! :slightly_smiling_face:


#161

I have a problem. I removed the pluggin while I decided to world edit my spawn into a new world, it copied the holograms and they are not classed as holograms for some reason and they are stuck there permanently (even without the pluggin!). Lucky they can stay perm if it can’t be fixed. but I would like this fixed D: