How to allow people to join my server


#22

[SPOILER=“Server Properties”] #Minecraft server properties
#Fri May 10 04:03:18 EDT 2019
spawn-protection=0
max-tick-time=60000
query.port=25565
generator-settings=
force-gamemode=false
allow-nether=true
gamemode=0
broadcast-console-to-ops=true
enable-query=true
player-idle-timeout=0
difficulty=2
spawn-monsters=true
op-permission-level=4
pvp=false
snooper-enabled=true
level-type=BIOMESOP
hardcore=false
enable-command-block=true
max-players=50
network-compression-threshold=256
resource-pack-sha1=
max-world-size=29999984
rcon.port=25585
server-port=25565
debug=false
texture-pack=
server-ip=0.0.0.0
spawn-npcs=true
allow-flight=true
level-name=world
view-distance=10
hellworld=true
resource-pack=
displayname=What’s a displayname?
spawn-animals=true
discoverability=unlisted
white-list=true
rcon.password=
generate-structures=true
max-build-height=256
online-mode=true
level-seed=
prevent-proxy-connections=false
enable-rcon=true
motd=\u00C2\u00A76Welcome to the Official Wiffle Pack Server![/Spoiler]


#23

Also the source port on your router needs to be TCP/UDP and, you may need 2 entries for it.Ports
PS. Sorry for the shitty paint skills…
Ensure that you have any port as the source and 25565 as the destination as users may be using a different port based on the networking of your/their device.


#24

Yeah I tried this in just about every way possible but it just doesn’t seem to be working because the ports are refusing to open for whatever reason.


#25

If the ports are refusing to work despite port forwarding, its typically that the computer with the ip isnt found (as in wrong ip) or it could be using the PNP protocol, which will only open the port if the ip in question is requesting the ports to be open


#26

@outflows - here are the details you need

  1. Open the server.properties file
  2. Update the server-port to use a port not in use. If this is the only Minecraft Server, the default of 25565 should be fine. Remove the rcon.port if you don’t need it.
  3. Change the server-ip to the internal router address (192.168.1.18) as long as this is not being used by any other device in your network. Verify by logging into your router and reviewing the device list. If the Minecraft Server is listed with this internal IP - no further changes are needed here.
  4. In the router admin portal, under Port Forwarding, add the port and IP of the Minecraft server to this list and save it. This lets the internet users find your server.
  5. In your antivirus software, you need to go into the advanced setup/configuration for Ports and enable the port 25565 to be accessible by all users on all pcs. For example, in McAfee LiveSafe, you would click on PC Security | Firewall | Ports and System Services and then click Add. The Service Name, Category and Description can be whatever you want to help you remember what it is. The Local TCP/IP Ports and Local UDP Ports should be set to 25565 (they could be different later, but that’s advanced configuration). Then Open ports to should be set to All PCs and then click Save. If there are other ports Minecraft is using (query.port, dynmap port, etc, repeat this for those also).
  6. Start your Minecraft Server.
  7. Open the Minecraft Client and add the server connection using the External IP and Port (e.g. 15.22.11.1:25565) and save it.
  8. Click on that entry in your list and you should be able to connect to it.
  9. Share the same IP:port with other users.

If during the startup of the server #6, you get errors that it cannot bind the port #, change the port number to another (e.g. 25515, 25100, etc.) and try again until there are no errors. Update firewall and Port Forwarding for the correct port.

If you are using a proxy server like Waterfall, BungeeCord, etc., the configuration is much different. Try first with the above before adding the proxy server.