How to disable Mixin's annotation processor? [Intellij]


#1

Hello, I need to disable mixin’s annotation processor on intellij (because it does not work correclty), but I don’t want to disable all of intellij’s annotation processors (because I use lombok). Is there any way I can force the annotation processor to not be used?


#2

It’s pretty much the foundation of Sponge. Have you considered maybe you are using it incorrectly and should ask for help?

Meanwhile, on the off chance that you’re right, Gradle 5.0 and above no longer automatically registers annotation processors. Upgrade to 5.0, and then put lombok in the annotationProcessor configuration.


#3

I have been asking for help lately, although with no success. Maybe I have something wrongly configured. I can’t use gradle 5 because for some reason forge gradle does not like it. Building with gradle works fine but when I Build Project with Intellij the mixins do not find the mappings. After searching for a while on Google the suggestion was to disable the annotation processor because it only works on Eclipse but I can’t because I am using lombok, another annotation processor.


#4

If you are using Build Project, don’t. You are supposed to use the build task from the Gradle tool window. Meanwhile, like I said, Mixin is the foundation of Sponge, and is used by a lot of mods too. It definitely works in IntelliJ (why would IDE even matter for a Gradle plugin?). Heck, there’s even an IntelliJ plugin for mixin integration.


#5

@pie_flavor it doesn’t work with the intellij annotation processor enabled though

there is a small workaround for it https://github.com/SpongePowered/Mixin/commit/ce9b186e44805fc6cd81d35edbc6e9d1f6a4c9a6

see https://github.com/SpongePowered/Mixin/issues/48

basically add this to your build.gradle

mixin {
       disableTargetValidator = true
}

#6

I have added this option but still can’t hit the Build Project option. I need to be able to compile through the IDE to be able to use Intellij’s Hot Swap feature. I tried to delegate gradle to the IDE’s build task, but after that the jvm running does not support hot swap. Any help?


#7

Are you ‘running’ through the IDE, or executing ‘debug’ through the IDE. There are two separate options in IDEs, one for debug and one for run. Hotswap only works in debug mode.


#8

intellij has run configurations, those will use gradle to build and run, which also supports hotswap
https://docs.spongepowered.org/stable/en/plugin/debugging.html