How to use SpongeForge and LuckPerms

So I ran /sponge version and it shows me this:

    Minecraft: 1.12.2
    SpongeAPI: 7.4.0-5ea6215
    Sponge: 1.12.2-7.4.6
    SpongeForge: 1.12.2-2838-7.4.6
    Minecraft Forge:
    JVM: 1.8.0_202/64-bit (Oracle Corporation)
    OS: Windows 10 (10.0/amd64)

When I add the LuckPerms plugin it doesn’t work (I put it in mods folder) anybody know why?

First of all. Does it show luckperms in green if you do the command

/sponge plugins

Secondly what version of luckperms are you using?

I have the same issue as above. Luckperms does not show in green when I run the command. I’m using Luckperms 5.4.18 with SpongeForge 7.4.7

Does the server log show any related errors during start-up? If it failed to load, there is usually something there to tell you why. Also, what version of Forge are you using?

The following are my versions

Minecraft 1.12.2
Spongeforge 1.12.2-2838-7.4.7

Could it possibly be that I’m using a LuckPerms version for Sponge 8, and using spongeforge 7.4.7, and the plugin isn’t backwards compatible?

Try the API 7.3.0 version at Luck / LuckPerms.
Luckperms usually claims back-compatibility to the stone age ( MC 1.8), but I note on the Ore page that LP versions 5.4.X target SpongeAPI 8.

It worked out…thank you very much for you prompt replies.