I can't get sponge to work with my server!


#1

Hello,
For some odd reason, I can’t get All of the mods 3 modpack to work with sponge, keeps telling me i need version 2815 (of sponge) or better to launch the server expect there’s no version 2815? Thanks for your help.


#2

You don’t need to match SpongeForge and Forge version exactly! Most of the time newer versions of Forge will work fine with the latest SpongeForge. So just download the latest SpongeForge version and try it.

I would recommend trying the latest recommended version of Sponge and seeing if it works: SpongeForge 1.12.2-2768-7.1.6-RC3616

(Obviously make backups before hand)


#3

Hi, thanks for the reply. I can get the server to lanuch, but it just doesn’t want to load up sponge! I enabled it in the config settings. Any ideas as to why? Thanks!


#4

What is the sponge file you are putting in, and what folder are you putting it in?


#5

I put in the version you recommended, I put it in the mods folder. When I create my own batch file, the server starts up, but doesn’t load sponge. When I use the custom modpack server launcher, this is the error I get:

**** ERROR ****
SPONGE has been enabled in settings.cfg but necessary files were not found…

To use Sponge:

  1. “MODS” folder must have a SpongeForge JAR matching Forge 2815

**** PLEASE NOTE ****
YOU MAY NOT RECIEVE SUPPORT from modpack devs if you use Sponge
Use at your own risk OR DISABLE SPONGE in settings.cfg

^ When I press to continue, it just shuts down the server.


#6

This message is sent from another mod on your server. It is saying that the configuration file of that mod needs to have a value changed in its configuration file to enable sponge.

Find out what mod it is and from there you can find the configuration file of the mod (typically in the folder called configuration) and then enable sponge on that mod