Issue with plugins loading

Greetings Everyone,

I have just migrated my server from Forge with mods to SpongeForge with mods by placing the spongeforge-1.12.2-2838-7.1.10.jar into the “/mods” folder. As I’ve seen in the logs the Sponge does load (I don’t know if correctly because I have never setup Sponge) but the Sponge does throw some messages in the log and it tells that its loaded.

The thing is the plugins does not load or they’re even recognized by SpongeForge, I tried installing them on the folder /mods/plugins and in just /mods.

When i Install them on /mods/plugins it does not show any messages in logs and when i do install them in /mods it pops a messages in the logs implying that for example “towny.jar is not a mod and it may cause some issue”. Tried to test some of the commands that the Plugins features on, but none works.

I"ll leave the servers logs here https://pastebin.com/cz9EpdTj

I’m using “forge-1.12.2-14.23.5.2838-universal.jar” to fit the version of Sponge “spongeforge-1.12.2-2838-7.1.10.jar”.

Any help regarding this?

Hi. So to install plugins to your server you put the plugins in your mods folder (unless you change the path in the sponge configs).

As for why your plugins arnt loading. Towny I believe is a plugin only for Bukkit. Sadly bukkit plugins do not run on sponge. Only sponge plugins run on sponge.

Here is the official download place for sponge plugins

1 Like

thank you that was my problem.