Item-despawn-rate not working?

Was trying to decrease the amount of time that dropped items stay around and changed it to:


Was testing it, and item despawns after 5 minutes… not 30 seconds. Is this a bug? Or is there somewhere else I need to change the configuration.
Changed global.conf, dimension.conf, and world.conf in /config/sponge.

1 Like

Make sure entity-activation-range is set to true under modules in global.conf.

Already had entity-activation-range=true

Should I copy over my config file?

Hmmm, I just tried this, too.
I had mine set to 12000 in all the conf files, just hadn’t had time to test it until you mentioned it.
Mine also despawns in 5 minutes, the default.

Currently using:

I’ve taken a look and can confirm it does nothing. From looking at the code, the despawn rate is only considered when an item goes ‘inactive’ (a feature of entity activation). However items never go inactive.

Hmmm, is this gonna be fixed or removed in the future?

Issue has now been fixed

1 Like

Thank you, I’ll update my sponge :slight_smile:

From my experience, it did not fix the issue (as of build 2054). Items are still despawning at the default 5 minute time. Let me know if you have a different experience. I am curious to know if I don’t have a setting right.

I’m using 2057, and its working for me. But I have it set to 30 seconds, and item despawns around then, sometimes a little longer,

1 Like

Thanks for the reply. I’ll give that build a shot.

Hi there.
I just tried with 2069 and I am getting the same result, items despawn after the default 5 minutes.
Anyone else besides us two have this issue or able to test?

Thank you,

Worked for me when I changed all three, just global config doesn’t work. Also make sure “entity-activation-range is set to true under modules in global.conf.”

If that doesn’t do it, then maybe simon can help. I’ll test if setting the despawn ticks greater than 5min worth later today if I have the chance.

I have taken another look at this. It appears to be an issue with sponge’s config system.
Basically it’s using the world-specific config rather than the global.conf. So to change the despawn rate for the overworld you need to change the file config/sponge/worlds/minecraft/overworld/world/world.conf

Hi there,

Yes, the setting is changed to my desired number in all 3 configs.
entity-activation is turned on as well, as it is by default.

Thank you kindly for looking into this.
As I mentioned on github, I wonder if it has something to do with the fact that I have a custom world name…

Also have a custom world name :confused: As long as it’s the file in config/sponge/worlds/minecraft/overworld/CustomWorldName/world.conf (and not /world/world.conf, since that would be for another world), don’t really get why it works for me and isn’t for you.

I still have players online on my server, so don’t want to close it for testing, but I’ll get to that later today. Maybe it’s because of some other mod/plugin?

1 Like

Hmph, okay.
Ya, there’s no /world/world.conf folder, just my custom world one.
Other than SpongeForge, I just have

pretty simple stuff… but if nothing gets figured out, perhaps next time I have a chance I’ll try running a server without those mods. I am about to leave on a trip, so won’t be back until next week to try it.
Thanks for continuing to help figure it out.