Just added sponge to my Tekxit Pi server and it crashes every time we go to the nether

I added sponge forge to my server to add permissions and now every time we go into the nether the server crashes a few moments later. I uninstalled foam fix after i tried disabling to config and it didn’t solve the problem.
here is a link to the crash report

Mind showing the full log. Not just the crash report?

Also have you applied the fixes for your mods?


I have just applied a fix to 1 mod and i will try it right now. Which log are you referring to the latest log or is there a different one, sorry im new to this

here is the latest log https://github.com/crush2021-1/latest-log/blob/cf8bdb72d67e61451e03b8ad73a08297cd407125/latest%20log

Yep the latest.log/latest.txt.

Your url gives a 404. Sure its the right link?

Try this 1 sorry I think it was set to private

That log looks like it was safely turned off. Mind showing one where you join and enter the nether?

But i will say in that log there are a lot of errors (not relating to sponge), all of which wont help.

But also the one i could see relating to sponge is the same as the crash report which seems to be about one of sponge’s exploit fixes. It’s likely that another mod is also apply the same fix so disabling it in the sponge config maybe the answer to that error. As for what exploit it is … Im not sure. All i know is this is the file its failing on mixins.bugfixes.world.chunksaving so likely something to do with chunk saving

Thats weird because im pretty sure I tested the mod changes and it still crashed. Anyways here is another log from after a crash latest-log/latest log 820 at 7efe42d6b77e1b08390ce35027f581de1232e3a1 · crush2021-1/latest-log · GitHub

latest-log/830 at 5cb35c67a6644f90b1752ae14587c57380dd3b1f · crush2021-1/latest-log · GitHub Here is another log. I thought I would add it because it gives a different disconnect message when leaving the nether than it does going into the nether.

Another update I thought it was only the nether that crashed the server, but going into any other dimension causes the same crash.

Have you tried disabling the sponge exploit fixes as mentioned before?

Ya I actually tried disabling everything in the sponge config that was active but it didn’t solve the problem.

Does that include




Ill see if i can see any other option in the code of 1.12.2 spongeforge to help you. But 1.12.2 is out of support and i wont be able to change the code for you

Turns out this is not a sponge file

mixins.bugfixes.world.chunksaving belongs to another mod. Should had seen this before but its from mixin booter.

You may have better luck looking for help there

Alright I’ll try it thanks.

There is no config for Mixin booter, so I tried a newer version of the mod but the server wouldnt even start with the newer version or without it at all.

I dont use it myself. But whats the error. Maybe its something i know?

without the mod it goes into a loop of trying to start and crashing.

Yep so a mod relies on the mod you removed.


Ya so I’m stuck I can’t edit mixin booster but the config for sponge hasn’t worked either