Kicked from sponge server


#1

I made a bungeecord(hexacord) network of servers. One was Sky Factory 4. I realized I had to use spongeforge to make it work with bungee cord because I needed IP forwarding or something. The server now works, and I play with my friend. The problem is every few minutes we get disconnected and sent back to the lobby. If we wait about 30 seconds we are able to connect again, it doesn’t crash. It appears that nothing happened on the server side log. On the client side there is a java.lang.IndexOutOfBoundsException error. I’m not sure what is going on, but if it is client side that would be strange because it happens to both players simultaneously.
Here is the part of the client log where we get disconnected: https://pastebin.com/B6k0XDCk
This is a very annoying issue and we have just been playing through it for weeks, but it would be very nice to get rid of it.


#2

Bungeecord is not recommended for use with Forge and SpongeForge; try using friendlier variants like Waterfall, or Velocity instead.


#3

I am using a variation called HexaCord. Is this a “friendly variant?”


#4

Looking at the github, it ended its life at 1.11. it supports the “basic forge” … so im going to go with no as your version of forge looks to be a 1.12.2 varient.


#5

Ok. I thought it was supported. I have been downloading it from here and it says it supports up to 1.14. I will try waterfall or velocity and report how it goes.


#6

In my experience, sites that redistribute mods tend to say it supports more versions then it actually does. Some of them do do a little testing, as in “does it boot. Yes. Great, label it as supported” and others dont even do that.

It may also (and probably is) that they are saying its supported with bukkit 1.14. Forge is a whole different beast


#7

Ok. Thanks for explaining. I’ll try out the other variants and see if they work better later today.


#8

I switched to waterfall and we still get the same issue.


#9

Could you send the error you get from waterfall? It will give a better understanding


#10

The strange thing is that waterfall doesn’t get an error. It just says we switched to the lobby as if we typed “/server lobby.” I guess I could still try velocity but I didn’t like that it doesn’t support bungee cord plugins. But I can sacrifice that if it means we can play without being constantly interrupted.


#11

Send the log anyway, there maybe something else that i can grab that is causing the error


#12

Here is the latest.log from the waterfall server. The two players are “WorkenInBlue” and “S00199.”


#13

Found the issue

73.202.89.6:52589|S00199] <-> DownstreamBridge <-> [SkyFactory4] - encountered exception
java.lang.IllegalArgumentException: Unknown meta type 14: Using mods? refer to disable_entity_metadata_rewrite in waterfall.yml
at net.md_5.bungee.entitymap.EntityMap.rewriteMetaVarInt(EntityMap.java:283) ~[waterfall-290.jar:git:Waterfall-Bootstrap:1.14-SNAPSHOT:c3d67e5:290]
at net.md_5.bungee.entitymap.EntityMap.rewriteMetaVarInt(EntityMap.java:135) ~[waterfall-290.jar:git:Waterfall-Bootstrap:1.14-SNAPSHOT:c3d67e5:290]
at net.md_5.bungee.entitymap.EntityMap_1_12_1.rewriteClientbound(EntityMap_1_12_1.java:151) ~[waterfall-290.jar:git:Waterfall-Bootstrap:1.14-SNAPSHOT:c3d67e5:290]
at net.md_5.bungee.entitymap.EntityMap.rewriteClientbound(EntityMap.java:101) ~[waterfall-290.jar:git:Waterfall-Bootstrap:1.14-SNAPSHOT:c3d67e5:290]
at net.md_5.bungee.connection.DownstreamBridge.handle(DownstreamBridge.java:139) ~[waterfall-290.jar:git:Waterfall-Bootstrap:1.14-SNAPSHOT:c3d67e5:290]
at net.md_5.bungee.netty.HandlerBoss.channelRead(HandlerBoss.java:112) ~[waterfall-290.jar:git:Waterfall-Bootstrap:1.14-SNAPSHOT:c3d67e5:290]
at io.netty.channel.AbstractChannelHandlerContext.invokeChannelRead(AbstractChannelHandlerContext.java:359) ~[waterfall-290.jar:git:Waterfall-Bootstrap:1.14-SNAPSHOT:c3d67e5:290]
at io.netty.channel.AbstractChannelHandlerContext.invokeChannelRead(AbstractChannelHandlerContext.java:345)

#14

Oh, I forgot to mention that I saw that last night. I looked at the file it mentioned and changed the option from false to true. Then it didn’t have that problem. But it still had the main problem of disconnecting. Unless this replaced the previous log and this is still an issue, in which case, what should I do?


#15

Get the latest log to us. The simplest way of finding out what the latest log is, is to delete all logs and then launch the server, join it, wait for you to disconnect from it and then shutdown the server


#16

I did this and got this log. I did get the same error so that must be the problem. I’m not sure how to solve it though, can you help?


#17

Take a look at this issue page, it says its closed but may give some insight into the error your having.


#18

I see the new option they’re talking about but on both true and false it still happens. I also don’t completely understand what the issue is/means. I hate to keep bothering you, should I ask this on waterfall github.


#19

You can ask them. I would recommend it as i am not familiar with the code.

The issue seems to occur due to custom entities. So it could be a badly behaving mod that requires the old way of saving entities, so it forces the value to be one or the other.