Lag problem Sponge 1.12.2


#1

Hello everyone!
I have already written several times with this problem here but no one could help me. Therefore, I will try all the information that I can gather on this occasion to hold in 1 post. Can someone help me. Now on the server all mobs are blocked except NPCs.
image
All plugins and mods have the latest version.

Ffter the server restarts, it starts to hang very often and for 5-15 seconds (freezes).

Plugins list (not red plugins 100%):
image

Mod list:
image
100% its not: IronChest, LagGoggles, ZeronItems, Various Oddities, VariedCommodities, ClassicCombat.

There were suspicions of mod CustomNPCs, Mo’Creatures and CustomMobSpawner, but removing them did not seem to help, but was not quite sure of that. It seems after removing the mod Mo’Creatures (and CustomMobSpawner) helped, but I can not be sure. When I returned it and blocked the spawn of all mobs, there were problems

Reports when server isnt laggy (no problems, 20 min after restart):
Online: 8

Spark:


Timing:
https://timings.aikar.co/?id=71706314d01f4490bd5b3f9732769c9c
LagGoggles:

VisualVM:

40 minutes after restart server (I have freezes right now):
Online: 12
Spark:

Timing:
https://timings.aikar.co/?id=80849d8096e64fcbb54488c63e7c5ce3

CPU:
https://hastebin.com/kupufofevi.pl

Memory (have problem with dump):

Its not Mirage plugins. I delete this, but its not he. I have this problem without this plugin.


#2

Without Mirage:
Online:16
Time after restart: 20 min
Frezzes: YES
LagGoggles:

Timing:
https://timings.aikar.co/?id=e3e6e7312f4045a09511f764fb1b8128

Spark: