Loading/importing a world with custom modifiers

Hi there,
I’m trying to import a secondary world with custom generatorOptions. I tried to import it with nuclues and project worlds. In both cases, the generatorOptions from the level.dat are not being taken into account.
I also tried creating a new world and replacing the generatorOptions afterwards. Unfortunately this didn’t work both cases either.

How can I resolve this issue?

@Slind did you ask for help from either of devs?

Yes, but I’m also looking for alternative solutions, because I doubt they can help/fix in a timely matter.

Is there really no way to load/import a secondary world (non main world/dim 0) with custom world generation (vanilla worldgen settings) settings?

You got to remember, Sponge is still in beta and is under development. Talk to the plugin devs, because you have waited 15 days so far and in that time they probably could of done something.

I talked to the nucleus and project world devs. The project worlds dev didn’t respond, the nucleus dev didn’t respond on the second message (clarification).

I’m looking for a solution and ideas here, nothing else.