LuckPerms | An advanced permissions plugin


#306

So I looked through this various times, Tried various things. It seems like by using /lp verbose im able to set TP to true but tp is still not allowed. also as an admin im still getting messages telling me that i cant do certain commands. is there a commands to grant full admin perms to myself? I own the server so i figure i should be allowed to fully to something if needed.


#307

Hello, is it possible to rank permission groups so that a lower rank group cannot ban a higher rank group?

I've been trying to look through the documentation, but couldn't find an example of this. Might not have looked hard enough but I lacked the time.

Thanks in advance.


#308

It would depend on the plugin you're using for bans.


#309

I am just using minecraft's own system for bans.
Do I need a plugin in order to achieve what I want?


#310

So just updated to the latest version of sponge and now none of my perms are registering... and my console is freaking out. Any ideas?

Id paste the log however the log is so big it crashes pastebin a gisthub...


#311

I would assume so. The default MC system doesn't support what you're looking for.

Most likely caused by this Sponge bug:

Should be fixed in the latest builds. :slight_smile:


#312

Alright thanks.

I'll have a look around then :slight_smile:

Do you happen to know a good plugin that only features kicking and banning?


#313

Hello, I 've got a question about (vanilla) operator status. First, I would like to thank you for LuckPerms, it works great and I appreciate it very much.

We are using Dynmap (Forge version) on our server. However, as a forge mod, we can't use LuckPerms to manage permissions for it. That wouldn't be a problem, since Dynmap Forge has two built-in ways to manage them: one is simple and checks wether a given player is operator, and the other is file based. However, with LuckPerms installed, neither of them work.
The problem is: apparently, the file based way is checking for OP status as well (based on this file from DynmapForge's GitHub page).

Giving myself OP is no problem - it's a small server, and we don't really need finer control over the permissions, at least not for DynMap - but OP does not work with LuckPerms installed:

[17:39:38] [Server thread/INFO]: [LP] Server Operator status has no effect when a permission plugin is installed. Please edit user data directly.

Is there a particular reason, or better, a workaround for that ? The bukkit version seems to have a configuration option for that, is a similar thing possible for the sponge version ?


#314

Sponge does not expose any API to manipulate or check for operator status. Additionally, when a permission plugin is installed, your OP status has absolutely no bearing over whether you have a permission or not.

The message you're seeing there is simply a warning.


#315

It worked when I disabled LuckPerms, but who knows.. I will ask the DynMap author. Thanks for your help :slight_smile:


#316

Dynmap needs to use EntityPlayer.canCommandSenderUseCommand("dynmap.permission.node", 4); to add Sponge permissions to non command checks, replacing the String (which does nothing in Vanilla/Forge AFAIK) with the permission node that Sponge will magically pick up to use


#317

Currently can't find command that outputs all permissions that are available on current server. I need that because some installed plugins do not have proper documentation and I don't know which permissions they have.

Also, at start we have 'default' group. I gave some permissions to it: destinations.home.create, destinations.home.remove, destinations.home.use, destinations.spawn.use, destinations.warp.use.

Then, player logs in. He in the 'default' group. But he doesn't have these permissions. Why?

> /lp group default permission info
[17:18:48] [pool-3-thread-1/INFO]: [LP] default's Nodes:
[17:18:48] [pool-3-thread-1/INFO]: > destinations.home.create (true)
[17:18:48] [pool-3-thread-1/INFO]: > destinations.home.remove (true)
[17:18:48] [pool-3-thread-1/INFO]: > destinations.home.use (true)
[17:18:48] [pool-3-thread-1/INFO]: > destinations.spawn.use (true)
[17:18:48] [pool-3-thread-1/INFO]: > destinations.warp.use (true)

> /lp user SomeUser info
[17:19:23] [pool-3-thread-1/INFO]: [LP] > User Info: someuser
[17:19:23] [pool-3-thread-1/INFO]: [LP] - UUID: ...
[17:19:23] [pool-3-thread-1/INFO]: [LP] - Status: PLAYER_ONLINE
[17:19:23] [pool-3-thread-1/INFO]: [LP] - Primary Group: default
[17:19:23] [pool-3-thread-1/INFO]: [LP] - Counts:
[17:19:23] [pool-3-thread-1/INFO]: [LP] - Permissions: 1
[17:19:23] [pool-3-thread-1/INFO]: [LP] - Temporary Permissions: 0
[17:19:23] [pool-3-thread-1/INFO]: [LP] - Prefixes: 0
[17:19:23] [pool-3-thread-1/INFO]: [LP] - Suffixes: 0
[17:19:23] [pool-3-thread-1/INFO]: [LP] - Meta: 0
[17:19:23] [pool-3-thread-1/INFO]: [LP] - Parent Groups:
[17:19:23] [pool-3-thread-1/INFO]: [LP] - > default
[17:19:23] [pool-3-thread-1/INFO]: [LP] - Cached Data:
[17:19:23] [pool-3-thread-1/INFO]: [LP] - Has contextual data: true
[17:19:23] [pool-3-thread-1/INFO]: [LP] - Current Contexts: (localhost=127.0.
0.1) (world=TMMedieval) (world=tmmedieval) (remoteip=127.0.0.1) (localip=127.0.0
.1) (localport=25565) (dimension=minecraft.overworld)
[17:19:23] [pool-3-thread-1/INFO]: [LP] - Current Prefix: None
[17:19:23] [pool-3-thread-1/INFO]: [LP] - Current Suffix: None

> /lp user SomeUser permission info
[17:20:55] [pool-3-thread-1/INFO]: [LP] someuser's Nodes:
[17:20:55] [pool-3-thread-1/INFO]: > group.default (true)
[17:20:55] [pool-3-thread-1/INFO]:
[17:20:55] [pool-3-thread-1/INFO]: [LP] someuser's Temporary Nodes:
[17:20:55] [pool-3-thread-1/INFO]: None


#318

/lp tree

Use the verbose command. I'd guess those aren't the right permissions.


#319

Hello.I set myself luckperms.* and minecraft.* true.But I still no permission to use /gamemode 1.
What should I do?:cry:


#320

I gave myself * and so far seems to be acting like regular OP with permission for everything. Not sure if that is the best way of going about it though...
Hope it helps!


#321

Would it be possible to toggle a permission with an in-game lever?
Thoughts?
Thank you!


#322

That’s generally regarded a bad idea. Some plugins expect you to not have every permission enabled.


#323

Command blocks and redstone would be your friend here.


#325

It sounds like another plugin is overriding the gamemode command, do /sponge which gamemode to find out what.


#326

Hey there,
Do you have a plugin in mind?
Also, what do you recommend if not *? What would easily replicate vanilla OP permissions?

Thank you,