LuckPerms | An advanced permissions plugin


#285

Awesome! Please paste the contents of the file here and send the link. :slight_smile:
https://gist.github.com/

Thanks for translating it, I know there's quite a lot of entries there. :stuck_out_tongue:


#286

Here is the link with the file translated:


#287

That's great! Thank you.

I've added the file to the main repo & wiki page. Hopefully other people can make good use of it. :slight_smile:


#288

This may have been answered already, however I was wondering if there is a special command to invoke changes that were manually made to json storage files in the luckperms folder. I have a perfect match to the permissions that I have enter in game or in console when comparing to a group that currently works. When i copy and paste the edits to the json on the server and save, however the groups and/or players are not receiving permissions.

I feel like im missing something simple


#289

You need to use /lp sync :slight_smile:


#290

So getting the same response. I will have to double check that everything is identical. Thanks! I'll report back if I continue to struggle


#291

Hello Luck, Sorry but I am having trouble with donation craft getting access with luck permissions. Donationcraft is suppose to have /buy available for everyone to use with no permission checking. I know in bukkit a permissions plugin such as pex would check the permission node within the donation craft plugin itself. Is luck permissions doing it another way? Sorry I'm a bit new to sponge api and how everything works. But long story short, I can't give access to the /buy command in donation craft. Any ideas?


#292

Sorry, I don't know what the permission is. If DonationCraft haven't got it documented anywhere, then you can use this to work out what it is.


#293

Is there a way to give yourself all permissions at once? This would be helpful cause im have an owner rank and i would like to give myself all permissions without typing over 300 permission commands.


#294

You'd need to give yourself the following permission: *

However, do know some plugins restrict your usage if you have a certain permission. Ie: "nucleus.socialspy.force"


#295

Does LuckPerms' flavor of regex have any special characteristics or limitations, or is it straight up Java?


#297

Straight up Java :slight_smile:


#298

I've tried using the permission

r=protectionperms\.item\.craft\.ne[_wo]|[_al]..m|[tu].y|:.a[pl]|cr|cke|it|un

and LuckPerms isn't behaving as if I have the permission protectionperms.item.craft.pixelmon:dusk_stone_helm despite my expected regex behavior

I've made sure that regex is enabled in the LuckPerms config, and I'm using LuckPerms-Sponge-3.1.15
Using a local server so no MySQL or anything.
Not sure if I'm missing something simple or if its a problem. Admittedly, I don't have a Java regex tester but it's behaving as desired on PHP, Javascript, Python, and golang

the simple R=sponge\.command\.plugins permission does grant me the sponge plugins command, however, so some regex does work


#299

I use this site to test. https://regex101.com/r/fwCSB7/1

The whole string needs to match for the permission to be granted.


#300

Interesting, even using that link if I go to the unit tests tab it works. I guess I'll have to approach differently. Thanks for the timely and helpful reply.


#301

Is there a way to allow me to bypass minecrafts spawn protection? ex: when I do /setworldspawn it puts a protection around it but everytime I want to edit my spawn I have to move the world spawn then move it back, which messes up players that do /spawn. Any ideas?

Servers "op-level-perms" is set to 1.

Edit: nvm figured it out: minecraft.spawn-protection.override


#302

so i cant seem to teleport. im also using journeymap but i dont think this is an issue because it uses the tp commands. I have granted permissions to my admins and moderators to use tp and it confirms true but it is still not being allowed. What am i missing?


#303

Do you have a mod like nucleus that replaces mc's tp commands?


#304

no i don't have nucleus. mostly just trying to get the waypoints in journey map to work or allow tp. would nucleus fix this and is there a full list of commands for luckperms available anywhere?


#305

Use this to work out which permissions are being checked for by the TP command:

A full list of commands can be found here: