LuckPerms and

Hi guys ! I have in exposed gamemode 2 . After installing luckPerms , players began to be issued gamemode 1 . Who knows what the reason is ? And yet , how to solve to open chests, etc.?
Server core :SpongeForge

You have messed up your permissions somehow. Check the Luckperms wiki and then take a good hard look at what your permissions groups are doing. It sounds like you have given them the minecraft.gamemode permission. As for inaccessible chests, perhaps you also have spawn-protection on - or a protection plugin.

If you need further help debugging, please share more information. Things like the versions of SpongeForge, Forge and Luckperms, and other plugins. Maybe a screenshot of the group permissions.

Доступ я не давал , пробовал пересобрать сервер , и закидывать новый “LuckPerms”(Без настроек групп) на чистый сервер . Тоже самое .
Раньше ещё была такая проблема как , спавн мобов отключал , но из за модов они всё равно спавнились , сейчас такого нет . Скриншот прилагается .


Why do you think the file is relevant? I asked for something completely different. The only thing worth noting there is that you have not set force-gamemode to true, but if players can change their gamemode anyway, then it is totally irrelevant.

Excuse me. I don’t understand what you need , exactly ? The problem I have described sort of .
In addition , Nucleon and worldedit are installed , but this is not because of them, because gamemode 1 instead of gamemode 2 begins to issue after the installation of LuckPrems . And the plugin LuckPerms new , no settings in it, I have not changed.
If you have to enter the kernel version , I took the recommended .

You have not clarified when they change gamemode - does it happen on login, or are they doing it by commands? A player’s gamemode will persist unless forcibly changed by the force-gamemode setting (on login) or by command. Unless some setting in Nucleus is changing things.

Installing a permissions plugin (like Luckperms) should override the vanilla /op system. Players then require permission for most commands, especially minecraft.gamemode. If you try the command /lp verbose true you should be able to see the permissions that are being checked, and what value they have. Try this when players are changing gamemode.

Let me also remind you that debugging is often helped by providing

Things like the versions of SpongeForge, Forge and Luckperms, and other plugins.

Sometimes bugs can be very specific to a version.

Ah, a little misunderstood . The player who went first will have to issue the Gm2 , and after installation LuckPerms issued Gm0 . The players themselves can’t change the GameMode .
PS.I’m from Russia (I Hope it won’t affect me). Therefore, some suggestions may be incorrect .

The following presumes ‘Nucleon’ means the plugin ‘Nucleus’.

If it’s happening on login, overriding the file, then your problem may be in the Nucleus world settings. The Nucleus wiki might be of help in general.

Sorry, I couldn’t find anything you said to me . The fact that I find it difficult to read the comments in the configs , or rather I do not understand them at all . One thing is the classic American language, another thing is working . Could you be more precise where I need the settings ?

And I don’t think it’s Nucleus . Because when entering is issued Gm 0, not Gm2 after installing LuckPerms

Nucleus has a per-world gamemode setting. From the page that I linked to (above):

–gm/–gamemode : the default game mode for players in the world. Defaults to survival.

See if that is the problem. If not, please double-check you haven’t set any permissions.

If you want any further assistance please provide the debugging information I requested in my first reply.

I need to get gamemode 2 …

I have already said that the problem is not that the players give themselves the Gamemode …

And that in is set to issue gm2, and after installing LuckPerms, issued on 2, 0 . How else to explain ???

You have explained, and I have answered.
THE DEFAULT WORLD GAMEMODE NUCLEUS SETS IS SURVIVAL MODE. YOU NEED TO CHANGE THAT. Sadly your reading comprehension is absolutely awful, and you won’t read documentation, so I am giving up.

You can’t give up , that’s my principle . If you don’t help me , others will .


Now the question is how to change the standard mode ?