Minecraft Forge 1.12.2 - The armors do not work

When I include the Sponge.Force software on my server the armors do not work. The armors do not protect.
Do you know about this problem?
Can you help me?

Server: Minecraft Forge 1.12.2 -

Best regards.

What version of SpongeForge are you using, and which mods?
I also STRONGLY recommend updating Forge, as more recent versions are patched to avoid the log4j exploit.

Is it possible to update “minecraft forge” without losing the world, or do you mean update the “Sponge forge”?

-Server: Minecraft Forge 1.12.2 -

-How can I know the version of “Sponge” I am using?

Updating Forge should do no harm. Make sure to use the installer so it updates the libraries.
SpongeForge has the version number in the filename. You can also use the command /sponge version.

Minecraft: 1.12.2
SpongeAPI: 7.3.0-13882aa47
Sponge: 1.12.2-7.3.1-SNAPSHOT
SpongeForge: 1.12.2-2838-7.3.1-RC4082
Minecraft Forge:
JVM: 1.8.0_312/64-bit (Private Build)
OS: Linux (4.15.0-163-generic/amd64)

Do you know any guide that can help me to update the minecraft forge version without reinstalling the whole server?

Is this the version I should install? “forge-1.12.2-”.

That looks like the latest Forge for 1.12.2, it will do. Use the Forge installer. It updates only the things it needs to. There is a page on SpongeDocs explaining how to do this (and maybe even in your native language).
You should also update SpongeForge to the latest 1.12.2 version as well, to see if your issue has been fixed in more recent updates.

I have tried updating “Forge” and “Sponge Forge”, but the issue with armor persists. I have also deleted all the mods and plugins that were in the “mod” folder, but the issue persists.

Minecraft: 1.12.2
SpongeAPI: 7.4.0-5ea6215
Sponge: 1.12.2-7.4.7
SpongeForge: 1.12.2-2838-7.4.7
Minecraft Forge:
JVM: 1.8.0_312/64-bit (Private Build)
OS: Linux (4.15.0-163-generic/amd64

I have also tried to create a new server with both updated versions, but the armor issue persists when including Sponge. When I remove Sponge it works correctly.

Minecraft: 1.12.2
SpongeAPI: 7.4.0-5ea6215
Sponge: 1.12.2-7.4.7
SpongeForge: 1.12.2-2838-7.4.7
Minecraft Forge:
JVM: 1.8.0_312/64-bit (Private Build)
OS: Linux (4.15.0-163-generic/amd64)

I attach logs in case you could help me. Thank you very much for your help.

Thank you for testing it out using the latest versions. If the bug persists, then it needs to be reported on the Sponge issue tracker. Your log files should be very helpful in tracking down the problem.

It is very strange that the problem persisted after you “deleted all the mods and plugins”.

I did one more test. I tried the Vanilla Forge version and it worked correctly, but in the version I told you about they do not work.

How could I check the information you indicate? I can understand computer science well, but I am a little lost to make that review. I have already searched several times and found nothing related to armor and my version.

It’s weird, because creating a new forge server works, but when adding Sponge is when the error occurs. Is there something in the sponge configuration that affects the gameplay or the stamina of the players?

You already seem to have most of the info needed to make a bug report - you have described the problem, provided version numbers, and showed a way to reproduce it. I searched too, and found nothing similar had been reported. You can be the first to officially report this issue if you want :wink:

I can’t recall anything in the sponge configuration files that is supposed to affect armour, but you can try changing things and see. Normally, I’d expect this sort of thing to be caused by a mod conflict - but if it’s only happening with SpongeForge and no other mods, it’s definitely a bug.

Thank you very much if you create the report.

I have tested with different lower versions of Sponge. I have detected that when testing with the version “SpongeForge: 1.12.2-2838-7.2.0” the armors work correctly.

Are there many differences between these versions of SpongeForge?

Thank You

OK, as you asked nicely, I made the issue for you: Armour is not working · Issue #3290 · SpongePowered/SpongeForge · GitHub
Can you also try out the very latest builds to see if this issue has gone? As of writing this, it is 1.12.2-2838-7.4.8-RC4141 (SpongeDownloads).

We have really nice templates to make it easy to report issues now, so if something else comes up don’t be afraid to give it a try.

In reply to your question; there are quite a lot of differences.

[Edit]: It seems [1.12.2] Vanilla-like armor is completely ignored when player takes damage · Issue #3231 · SpongePowered/SpongeForge · GitHub is probably the same issue, which I missed last time because I forgot to change to the API-7 branch.

Thank you very much for your help, you were very kind. I will follow the thread you posted and try to fix it somehow.