Minecraft server world corrupted


#1

So the past week i’ve been working my ass off on my server and it was done, everything worked.
Suddenly next day i get on the server won’t start anymore? I contacted my host and they said remove Sponge, well i can’t it’s my core plugin. He said then it might be a corrupted world, i saved my old world and made a new one and it started up. But i want my old world ofcourse, with my spawn and all that. Here’s a crash report of my old world start up: https://pastebin.com/bJL51R70

I’m clueless, Region fixer said nothing was the problem so i don’t know anymore, please help! ;-;


#2

The corrupted file is level_sponge.dat, which can be damaged if the server shuts down unexpectedly. Replacing that from a backup would be ideal. There should also be an older copy of the file in the world folder, called level_sponge.dat_old, which you can try as a replacement - or you can try deleting it and let it regenerate (which may be more problematic).


#3

So i gotta delete the level_sponge.dat and rename the other one to the one i deleted right?


#4

Pretty much. Make sure you get the right one, as each world should have such a file.


#5

I just did and the server still won’t start up sadly, are there any other options?
I completely forgot to make a back-up since i was tired of finishing the server up and went to sleep so i had no chance to back up…


#6

I also have a old level.dat, is that a solution or is that not the problem?


#7

The log will usually tell you which file is messed up. Don’t mess with what ain’t broken.
You can try starting the world without Sponge, and Forge should prompt you to run an automated backup anyway, so it should do little to no harm. If it still works OK, then just get rid of the level_sponge.dat files completely, and let them regenerate.


#8

Now it won’t start but won’t crash, it’s taking it’s sweeeeeet time starting <.<


#9

Forge requests you to run backup by entering /fml confirm - make sure you aren’t waiting on that (or for the backup to run).


#10

You absolute legend, alright what do i do now before throwing in Sponge again?


#11

If it started OK, then shut it down again safely and

Other things may go weird if the world UUID gets changed, so other configs might need to get regenerated too (like the sponge configs), but cross that hurdle when you get to it.


#12

Okay so, delete the level_sponge.dat and level_sponge.dat_old and then drop spongeforge in?
Then start?


#13

Yes. You should now have a backup anyway. Make sure you don’t have similar problems with the level_sponge.dat files in DIM1 and DIM-1 as well.


#14

Ohh all the level_sponge.dat files should be deleted there too?


#15

It’s up to you; they may be fine, and have useful data. If it crashes with the same error then you know what files to blame.


#16

Alright! I know what to do nex time, i am so grateful for your help!
I got my old world back i worked hard on! Thank you so much,
any way i can like give credits to you to make your forum rank go up or something? x)


#17

Lmao i’m back, so i deleted every single sponge file in DIM1 DIM-1 and world and it just won’t startup with Spongeforge :frowning:


#18

An error log would be more informative. You may have to regenerate the sponge config files as well.


#19

Yes my bad
https://pastebin.com/4wDDsSvx


#20

From the bit below, it looks like the problem is in the world “ultra”. Did you deal with that one too?

* Failed loading Sponge data for World [ultra]}. Report to Sponge ASAP.
20.07 02:47:25 [Server] INFO java.io.EOFException: null
20.07 02:47:25 [Server] INFO at java.util.zip.GZIPInputStream.readUByte(GZIPInputStream.java:268) ~[?:1.8.0_211]