MMCReboot [2.3.0] - A server restart plugin


#41

Reboot not working. Please fix for spongeforge-1.10.2-5.2.0 latest version.


#42

I cannot replicate this on my test setup. If this keeps happening please submit a report here: https://github.com/ModdedMinecraft/MMCReboot-Sponge/issues

with the Sponge version used, Any FML-Server-Log files for the time relating to the incident and your current config file setup.


#43

does it work with api 6.1.0 on mc 1.11.2? if doesn't, will you do? thanks


#44

There is no compilation errors so the current build should still work with 6.1.0 perfectly fine.


#45

Do you think you could replace the default “Server closed” message with the custom reason for a reboot?


#46

im using Nucleus for this cause all MMCReboot does is a /stop

and with Nucleus u have this:

kick-on-stop {
#If true, Nucleus will kick all users just prior to the server stopping.
enabled=true
#The message to display to players when restarting the server. Overridden when using the /stop [reason] command.
message=“Server is restarting”
}


#47

I gave myself all the following permissions and I cant seem to start a reboot with /reboot vote or /reboot now. I can do it in the server console command but not in game. I even gave my group the permissions “I use Lucky Perms”. Any idea whats up? The error I get is “You do not have permission to use this!”

mmcreboot.reboot.vote - start a vote to restart the server
mmcreboot.reboot.now - restart the server immediately
mmcreboot.reboot.start - set a timer to restart
mmcreboot.reboot.time - check the time until a restart
mmcreboot.reboot.cancel - cancel any restart/vote in progress
mmcreboot.reboot.bypass.vote - bypass the initial checks for /reboot vote
mmcreboot.reboot.toggle.vote - in-game toggle for enabling and disabling of the voting system


#48

Could you provide the sponge version you are using?

Also check your own permission node using

/luckperms user {user} permission check mmcreboot.reboot.vote

and the others if need be. If you have the permission then it should return true. If it is false then it is not a fault of the plugin and most likely due to an error somewhere else like user error, Luckperms or Sponge


#49

Thank you for the reply,

The version of Sponge I am using is:
Sponge Forge 1.12.2-2655-7.1.0-BETA-3080

I am willing to change to another version if need be.

I ran the command and it returned:
user has permission mmcreboot.reboot.vote set to undefined in context global

Is there a config file named global I need to ajust? I looked around and found the one in the sponge folder but id didint have anything about mmcreboot in there.


#51

Is it possible to also have a BossBar to countdown when its restarting?


#52

Server shuts down fine but doesn’t reboot after it stops?


#53

#54

I will look into this, If there is an API for it then it should be possible :slight_smile:


#55

Thank you, and if its possible can you add a voting system where 60-80% people online that vote yes, the server will restart


#56

Already has this system in place, There is configuration options for it in the config file too :slight_smile:

That was the original idea that i wanted for my personal server


#57

Thank you that works dident notice it :eyes:


#58

Hi there!
Your plugin looks great, but unfortunately the main function doesn’t work for me: Whenever the timer hits 0 seconds the message “Server is restarting, we’ll be right back!” appears, but the server doesn’t restart because in the console it says:

“touching restart at C:\server.\config\mcreboot\restart.txt”
and then “Something wen wrong while saving & stopping!”
The txt file is blank.
I am using spongeforge 1.12.2

I hope you can help me. Thank you in advance!

PS: This is the text of my start.bat:
@ECHO OFF
SET BINDIR=%~dp0
CD /D “%BINDIR%”
:start
java -Xmx2G -Xms2G -jar forge.jar -o true
goto start

–> the server loops a restart after I hit “stop”

PPS: I also have nucleus installed --> is there a way of setting a timer for a nucleus restart as an alternative?


#59

I am unsure where to start with this. Was this restart triggered via the automatic timer, TPS timer or manually triggered?

You can also set it to run commands in the configuration (Which can run something instead of the plugin triggering the stop)


#60

Thank you for your reply!

I tried both the command (manually) and the 2h timer - both showed the same result - The server keeps running and the timer continues in negative digits.
When I force the plugin to use the “stop” command instead, I get another error message saying:

[Timer-20/INFO] [mmcreboot]: [MMCReboot] Running Command
[23:36:48] [Timer-20/INFO] [STDERR]: [java.lang.ThreadGroup:uncaughtException:-1]: java.lang.IllegalStateException: CauseStackManager called from off main thread (current=‘TimerThread{class=class java.util.TimerThread, name=Timer-20, priority=5, group=net.minecraftforge.fml.common.thread.SidedThreadGroup[name=SERVER,maxpri=10]}’, expected=‘Thread{class=class java.lang.Thread, name=Server thread, priority=5, group=net.minecraftforge.fml.common.thread.SidedThreadGroup[name=SERVER,maxpri=10]}’)!
[23:36:48] [Timer-20/INFO] [STDERR]: [java.lang.ThreadGroup:uncaughtException:-1]: at org.spongepowered.common.event.SpongeCauseStackManager.enforceMainThread(SpongeCauseStackManager.java:71)
[23:36:48] [Timer-20/INFO] [STDERR]: [java.lang.ThreadGroup:uncaughtException:-1]: at org.spongepowered.common.event.SpongeCauseStackManager.pushCause(SpongeCauseStackManager.java:107)
[23:36:48] [Timer-20/INFO] [STDERR]: [java.lang.ThreadGroup:uncaughtException:-1]: at org.spongepowered.common.command.SpongeCommandManager.process(SpongeCommandManager.java:298)
[23:36:48] [Timer-20/INFO] [STDERR]: [java.lang.ThreadGroup:uncaughtException:-1]: at net.moddedminecraft.mmcreboot.Main.useCommandOnRestart(Main.java:493)
[23:36:48] [Timer-20/INFO] [STDERR]: [java.lang.ThreadGroup:uncaughtException:-1]: at net.moddedminecraft.mmcreboot.Tasks.ShutdownTask.run(ShutdownTask.java:40)
[23:36:48] [Timer-20/INFO] [STDERR]: [java.lang.ThreadGroup:uncaughtException:-1]: at java.util.TimerThread.mainLoop(Unknown Source)
[23:36:48] [Timer-20/INFO] [STDERR]: [java.lang.ThreadGroup:uncaughtException:-1]: at java.util.TimerThread.run(Unknown Source)


#61

What plugin version are you using? It seems like this error was from a previous version that was fixed

Github no longer gets release versions, All newer versions are hosted here:
https://ore.spongepowered.org/leelawd93/MMCReboot/versions