Mods not working!

Hey, i tried going through a few mods and none of them are working while i have plugins loaded.

You haven’t given us anything to work with. Please provide such information as the mods and plugins you are trying to use, the version of Sponge you are running, the version of Forge you are running, Java version, etc.

oh sorry about that lol! the plugins are:

And the mods are:
MrCrayfish Furniture Mod
RPCraft Lock and Keys
Security Craft

Are any exceptions being thrown? Server logs?

no. the problem is that the tabs that are in the mods show up in the inventory gui but when you click on them, there is nothing in the slots. They’re blank. However rpcraft lock and keys did show the items in the slots but when i took them out of slot to put them in my inventory, as soon as the item was placed in my inventory, the server signed me out. I sign back in and tried a different one and it did the same thing

Are the mods on both the client and the server?

1 Like

sponge plugins are on server and mods are on client

The mods need to be on the server as well.


well i’ll be damned… O.O

HOLY CRAP IT WORKED!!! This is the happiest moment of my life that it could make a grown man cry!:joy:


I cant install mrcrayfish gun mod and vehicle mod and The same thing happends please help

Some helpful advice:
(1) Start your own thread, this one is 6 years old and largely unrelated.
(2) Provide more information on the problem. We don’t even know what version of Minecraft you are using.
(3) Always try it with the most recent versions of SpongeForge and Forge (for whatever MC version you use) first.