My server laggy for no reason

First of all my server specs;
i7 7700K OC (5ghz)
64GB DDR4 2400mhz RAM
x2 480GB Nvme
1Gbps Internet
OS:Ubuntu Server 17.10 “Artful Aardvark”
Java: Java 8 64bit Update 161

Plugins i use:

Java Arguments i use atm: -Xms16G -Xmx16G -XX:+UseG1GC -XX:+UnlockExperimentalVMOptions -XX:MaxGCPauseMillis=100 -XX:+DisableExplicitGC -XX:TargetSurvivorRatio=90 -XX:G1MaxNewSizePercent=60 -XX:G1NewSizePercent=35
-XX:InitiatingHeapOccupancyPercent=15 -XX:G1MixedGCLiveThresholdPercent=50 -XX:+AggressiveOpts -XX:+AlwaysPreTouch -jar FTBserver-1.12.2- -XX:+UseLargePagesInMetaspace

Timings: Aikar's Timings Viewer
Snapshot / NPS File: test.nps - Google Drive

I’m running FTB Revelation server but for some reason it’s laggy as hell and for some reason my server doesnt use the CPU it’s only uses 2% of the CPU and TPS about 5, 6 it doesnt make any sense.
(Server running on ubuntu, 64bit java lastest)

Please post your plugin list and your startup script.

Hello, i do not use any java arguments and i do not have start up script because i’m using AMP (Cubecoders) console, it does the start up script for me and the plugins i use;

The startup script can be managed externally, but it is still important for us to know what the actual arguments are. Can you at least provide the settings you’ve put into the manager?

I guess it’s all i have

And have you recorded any timings?

How do i do it?

A quick look shows what’s happening.

Somehow, you’ve got almost 1900 chunks loaded with 3 players and over 100,000 tile entities. I don’t even know how that happens.

My experience with modded servers is limited and I’ve never worked with FTB, so on that I’m in the dark. Perhaps these numbers are normal for servers running some of these mods, but I find that unlikely. You’ll have to figure out why this is happening and how to reduce those numbers.

I did used backup back in days because something broke the world file then after i use the backup some how 3 people lost their base and they found a mountain than their base in the same place, i’m guessing that backup might broke the world and causes that kind of problems then

That doesn’t sound very likely. A backup just consists of copying the files, not interpreting them; if anything got screwed up, it would just be corrupted instead of incorrect data. Orphaned tile entities are possible, but they’d be highly unlikely to be created from backup.
It’s likely a mod issue of some sort; you could file an issue on the Revelation project page.
It’s also possible that it’s a player issue. IIRC Revelation doesn’t have RFTools Dimensions, but is it possible that someone has found some other way to create a world made out of tile entity blocks? Ask your players if they have been doing anything crazy lately involving machines or other forms of processing. Specifically from the report it looks like there’s a lot of Thermal Expansion machines slowing stuff down.

I checked the world files and there is nothing weird about those, world files are okay. I got nps (snapshot) file for visualvm just from few minutes ago but i have no idea how to read it

The thing i dont understand the most, why it’s using only 2% of the CPU.

As someone who has expirence running modded servers, 100k tile entities is VERY excessive for just 3 players… If it has been online for a long time and there were chunk loaders which persist after the user goes offline and there had been many, that could explain it, but the timings only show, what, 10 minutes? Utterly nuts, never seen mine go above 40k and that was with over 10 players online and chunk loaders.

1 Like

That 3 players from staff team because i turn off the server till i fix this TPS problem, i usually have +25 online players and there is +250 whitelisted players it’s been 1month, i can not turn off the offline chunkloaders since FTBU dont let me to or i do something wrong about it.

Btw: My java arguments;
-Xms16G -Xmx16G -XX:+UseG1GC -XX:+UnlockExperimentalVMOptions -XX:MaxGCPauseMillis=100 -XX:+DisableExplicitGC -XX:TargetSurvivorRatio=90 -XX:G1MaxNewSizePercent=60 -XX:G1NewSizePercent=35 -XX:InitiatingHeapOccupancyPercent=15 -XX:G1MixedGCLiveThresholdPercent=50 -XX:+AggressiveOpts -XX:+AlwaysPreTouch -jar FTBserver-1.12.2- -XX:+UseLargePagesInMetaspace

The server uses 1% - 3% CPU and this doesnt make any sense

Note: We transfer the server another stronger machine than old one, old one were using 10- 17% CPU (the guy who made it left the team, i can not contact with him) and now we cant fix this CPU issue

Meanwhile tps is 3 and CPU only uses 1% not even 2%

Yeah, don’t let players use those chunkloaders. That’s a bad idea. 250 players total, 20 chunkloads per person, and you let them do it with impunity? 1897 chunks sounds about right. You really need to disable that. I don’t know how, but there’s no way FTBU would put a free chunk loader in without a way to disable it.

Players got 8chunk loaders per person, i spoke with FTBU dev. He isnt helpful or friendly at all, he just said “that version (lastest) is broken” and that was all, idk how to do it either, i tried few stuffs but not worked

Any idea about the CPU usage?