Need Help with EssentialCmds

I keep downloading it but the server keeps crashing.

This is what it says

[22:17:58] [Server thread/INFO]: Starting minecraft server version 1.8.9[22:18:05] [Server thread/ERROR]: Encountered an unexpected exceptionjava.lang.ClassCastException: java.util.ArrayList cannot be cast to java.lang.Stringat org.spongepowered.mod.plugin.SpongeModPluginContainer.getSortingRules( ~[SpongeModPluginContainer.class:1.8.9-1722-3.1.0-BETA-1136]at net.minecraftforge.fml.common.Loader.sortModList( ~[Loader.class:?]at net.minecraftforge.fml.common.Loader.loadMods( ~[Loader.class:?]at net.minecraftforge.fml.server.FMLServerHandler.beginServerLoading( ~[FMLServerHandler.class:?]at net.minecraftforge.fml.common.FMLCommonHandler.onServerStart( ~[FMLCommonHandler.class:?]at net.minecraft.server.dedicated.DedicatedServer.func_71197_b( ~[ko.class:?]at [MinecraftServer.class:?]at [?:1.8.0_92][22:18:05] [Server thread/ERROR]: This crash report has been saved to: /home/minecraft/servers/mine97881/./crash-reports/crash-2016-08-30_22.18.05-server.txt

What is it exactly you keep downloading?

If you want anyone to help you with the issue, you must give more information.

Are you trying to run the Bukkit version of Essentials on a Sponge server? If so, it won’t ever work.

no im trying to download essentialcmd sponge mod on to my pixelmon server but it keeps crashing

Then it would help very much to have the correct name of the plugin (I fixed the title). You’re best pursuing this on the plugin’s thread, rather than starting a new one (I note that you’ve already reposted this there, thanks).
Other important things to include in reporting bugs are the Java, Forge, SpongeForge, or SpongeVanilla versions, and the other plugins or mods you’re trying to use with it.

ok thanks I would do it

Im Using
Java 8
Sponge Version: spongeforge-1.8.9-1722-3.1.0-BETA-1136.jar

This is probably your problem. That build of Sponge is ancient. Try updating to a more recent version - the latest for Minecraft 1.8.9 as of this moment is build 1691, recommended build is 1653.

I tried that but it still doesnt work
Is there any where to fix it

Please post the log again with using the newer sponge version.

I tried the new version but my server does not even start and does not show anything in the console?

How do you start the server? I am sure that something is shown.

The more info the better. Even if you believe there is nothing in the logs you should paatebin them anyways along with Sponge version, Forge version(if applicable) and a list of plugins and mods(if applicable). This allows for us to get a better understanding what’s going on. Without this it’s a guessing game

Im using pixelmon 2.4.7
Java 8
And Using SpongeForge Version spongeforge-1.8.9-1722-3.1.0-BETA-1136
And The Mods Im Using With Is some of the sidemods on the pixelmon website and worldedit and nations

i ran the server with the latest forgesponge and it went good but i dont have essentials cmd
When i ran it with essentialcmds it crashed.

Then report it to the developer of that plugin. [DISCONTINUED] EssentialCmds [v8.1.14]