Need help with Velocity


#1

I currently have 3 Servers

A 1.14.4 Vanilla Spigot Server
A 1.12.2 Modded forge server
& a 1.12.2 PaperSpigot Hub

I’m fully able to connect to the Hub on vanilla minecraft but when it comes to trying to connect on Forge I am constantly hit with an error

22.08 04:40:01 [Disconnect] User Elixirs has disconnected, reason: Invalid payload REGISTER!
22.08 04:40:01 [Server] INFO at java.lang.Thread.run(Unknown Source) [?:1.8.0_181]
22.08 04:40:01 [Server] INFO at net.minecraft.server.v1_12_R1.MinecraftServer.run(MinecraftServer.java:666) ~[patched_1.12.2.jar:git-Paper-1584]
22.08 04:40:01 [Server] INFO at net.minecraft.server.v1_12_R1.MinecraftServer.C(MinecraftServer.java:774) ~[patched_1.12.2.jar:git-Paper-1584]
22.08 04:40:01 [Server] INFO at net.minecraft.server.v1_12_R1.DedicatedServer.D(DedicatedServer.java:423) ~[patched_1.12.2.jar:git-Paper-1584]
22.08 04:40:01 [Server] INFO at net.minecraft.server.v1_12_R1.MinecraftServer.D(MinecraftServer.java:850) ~[patched_1.12.2.jar:git-Paper-1584]
22.08 04:40:01 [Server] INFO at net.minecraft.server.v1_12_R1.SystemUtils.a(SourceFile:46) ~[patched_1.12.2.jar:git-Paper-1584]
22.08 04:40:01 [Server] INFO at java.util.concurrent.FutureTask.run(Unknown Source) ~[?:1.8.0_181]
22.08 04:40:01 [Server] INFO at java.util.concurrent.Executors$RunnableAdapter.call(Unknown Source) ~[?:1.8.0_181]
22.08 04:40:01 [Server] INFO at net.minecraft.server.v1_12_R1.PlayerConnectionUtils.lambda$ensureMainThread$0(PlayerConnectionUtils.java:14) ~[patched_1.12.2.jar:git-Paper-1584]
22.08 04:40:01 [Server] INFO at net.minecraft.server.v1_12_R1.PacketPlayInCustomPayload.a(SourceFile:8) ~[patched_1.12.2.jar:git-Paper-1584]
22.08 04:40:01 [Server] INFO at net.minecraft.server.v1_12_R1.PacketPlayInCustomPayload.a(SourceFile:58) ~[patched_1.12.2.jar:git-Paper-1584]
22.08 04:40:01 [Server] INFO at net.minecraft.server.v1_12_R1.PlayerConnection.a(PlayerConnection.java:2677) ~[patched_1.12.2.jar:git-Paper-1584]
22.08 04:40:01 [Server] INFO at org.bukkit.craftbukkit.v1_12_R1.entity.CraftPlayer.addChannel(CraftPlayer.java:1366) ~[patched_1.12.2.jar:git-Paper-1584]
22.08 04:40:01 [Server] INFO at com.google.common.base.Preconditions.checkState(Preconditions.java:444) ~[patched_1.12.2.jar:git-Paper-1584]
22.08 04:40:01 [Server] INFO java.lang.IllegalStateException: Too many channels registered
22.08 04:40:01 [Server] ERROR Couldn't register custom payload

Would love some help on how I could fix this or what am I doing wrong that is causing the error for the Forge side.


#2

We are neither Spigot, nor Forge, nor Velocity. You should better ask on Velocity forums.