Nucleus: The Ultimate Essentials Plugin (MC 1.10.2, 1.11.2, 1.12.2)

Ah my bad.

I’m sure that it isn’t in the wrong group, since these 2 permission nodes are added to every group in existence.
And yes @djxy

EDIT:- Project portals was interfering. Sorry for that unnecessary bump

I’ve had a problem with the original EssentialCMDs and this project as well; where either my warps don’t work, it tells me they don’t exist (but they do) or it just completely removes them.

What error messages does Nucleus give you? It might be because your world’s UUID changed for some reason.

I created a warp called “sghousing” yesterday, later in the day I tried warping (/warp sghousing) it says; “sghousing doesn’t exist” so I checked /warp list, no warps. (In Essentialcmds I’d have the same issue, but the warp would be in the warp list.) Also, nothing comes up in the console.

Let me try again right now, with a new one;
After testing it, with several warps, logging, and restarting it appears to be working. Maybe I jumped the gun a bit? When the same issue happened with the new plugin I assumed it would continue as with the old, but so far so good. I’ll return if I see it again and keep note of any errors and re-trace my steps best I can.

PS; I’ve noticed that “setspawn” moves the player a bit, which can mess it up. I’ve appeared inside blocks, and under them as well.
Spawn set;
When warped to Spawn;


Sorry to bug you again, but it seems that there is an issue with using /rtp in other “custom” worlds/DIMs (Not the nether or end). It seems to crash the server if you use it in a custom world. If you can’t fix this or reproduce it could you make a way to block certain commands is specific worlds?


Are you able to let people migrate from the plugin Kits to Nucleus?

I have an issue that makes total sense. Being Sarcastic. Can you help out?

First did the command “/kit add PokeFan”
Created succesfully

Second “/kit onetime PokeFan true”
Got error how it didn’t exist even though I just created it

Third “/kit PokeFan” (To test what the heck was going on)
Says I dont have perms but I have a wildcard “nucleus.kits”

Anyway to fix this issue? I had all my kits before but all my warps and kits got randomly deleted. :confused:

SpongeForge: 1762 (API 4.2.0)
Forge: 1890
Nucleus: 0.12.1-S4 (1.8.9)

@dualspiral Previously I used the object from the black list. A bucket of lava. Errors in the logs no.

_🏆 AdventureMMO [v2.0.7] [API 4/5/6] - #127 by anon34495435

In my case the problems with the equipment began without repair. And today I managed to record the video. I never found the cause.


@Txk I haven’t written a converter, no, but your other issue concerns me. I’ve fixed multiple issues with kits - that should not be happening. I feel like I’m going to have to just start from scratch with the Kits stuff, because it’s just a myriad of fix over fix over fix, and I think we can do better.

However, the fact you have problems with managing the kit once you’ve create the kit does not make sense. Are there any errors or stack traces? Were you running Kits at the same time?

The permission thing - make sure you have nucleus.kit.base too.

Version 0.13 is now available for Minecraft 1.8.9 and 1.10.2

This version supports Sponge API 4.1 and 5 (1.8.9 and 1.10.2).

IF YOU ARE RUNNING MC 1.10.2 you MUST be running SpongeForge for API 5.0, 5.1, or current builds from API 6.

This release has the follwing new features:

  • Add, nucleus.tempban.offline, permissions.
  • Add /world gamerule and /world gamerule set commands.
  • Add /kit set alias - /kit setFromInventory
  • Add /kit add alias - /kit createFromInventory

The following are new features for 1.10.x/API 5 ONLY:

  • Added /invsee
  • Added /enderchest
  • Added /kit edit and /firstjoinkit edit for editng kits via an inventory GUI.
  • Added /kit create for creating a kit via an inventory GUI.

Download from GitHub Releases: Release Version 0.13.0 (for 1.8.9 and 1.10.2) · NucleusPowered/Nucleus · GitHub
Command documentation is already up to date:

As I sometimes do, a shoutout for the community. This plugin was created for the community, and I enjoy the challenge of creating it. I must reiterate that I’m not looking for monetary gain, this is just fun for me. While it’s not perfect, and there have been frustrating bugs at times for you all and I, please be assured that I am doing my best to stamp them out. Thanks to all the reports and help people have given. Thank you all for sticking with me, hopefully I can harden the plugin over the next few releases!


We can add this feature, if you could add this to our GitHub issues, I can work on this ASAP

It would be nice to see the CommandSigns in the kernel. It is planned?

Thank you! This is something very much needed!

I’ll add it, to do at your lesiure.

Version 0.13.1 is now available for Minecraft 1.8.9 and 1.10.2

This is a bug fix release that many people will probably welcome!

  • If a data file fails to save, Nucleus will use a backup to return the previous state of the file, this should prevent files from being blanked, so in case of error, not everything will be lost.
  • Allow kits to have items that have no enchantments but have the enchantment shine (thanks to @ryantheleach for the report).

See Release Version 0.13.1 (for 1.8.9 and 1.10.2) · NucleusPowered/Nucleus · GitHub for downloads and releases. For other features in the 0.13.x series, see the 0.13.0 release annoucement.


Fantastic update! One of the best! Keep it up!

So apparently if you do /vanish and then once your vanished you do /afk it will make it so you can’t be kicked by the afk kicker.

I have an issue where I have a general.json file that wont read my warps after updating Nucleus. they are still in the file but completely will not show in game when using /warp list or /warp warpname


I have tried clearing it and just putting back in the warps, however it will not work…

I have also tried going back to the previous version but it wont show on that one either.

[Edit-Fixed] Had to manually recreate the warps ingame going to each location and using my old config to find them. Also updated to 1844 from 1843 build of SpongeForge.

Players who have the correct perms for the kit are not able to use it. Their inventories are also empty at the time. Using the most recent 1.10.2 build.

Error message: “Kit cannot be added to inventory”

I’m having the same issue.