PEX and Nucleus don't show Prefixes

I need some help…
I’m using PEX and Nucleus in my server (1.10, Sponge 1973)
I already configured twice but i can’t see prefixes…
My chat is like vanila style, everything white :frowning:

I already tried with more plugins for chat management…
The only one that worked is EssentialsX (From Spigot, using PoreRT) but does not work at 100%…

Well, my first question is are you sure that Sponge is loading the mods properly, also for name colors I know Nucleus uses a namecolour/namecolor option instead of tailing the prefix, Also since you just started configuring Luck Perms is pretty great just saying.

I think the Templetes for your Nucleus config are overwriting it. We only use pex for prefixes (Of course Nucleus needs to be installed as well) and it works fine. Although you could probably tag the Nucleus dev and they would know.

I try with LuckPerm.

Good luck, if you need help configuring things let me know I’d be happy to take a look.

I tried with LuckPerms but nothing changed…
What i do:
/luckperms creategroup Admin
/lp user myusername parent set Admin
/lp group admin meta addprefix 100 “&c[Admin]”
/lp group Admin meta set rank Admin
On Nucleus, same config as topic start…
But nothing works…
Also colors in chat not works (&2Hello)


Try making a backup of your Nucleus config, then completely clear it out and let nucleus generate it again. Log in game and see if colors appear with these defaults. Also make sure your sponge version is up to date, as well as nucleus.

@BokiP22 Your version of Nucleus, Sponge & Forge, plus a server log might help, especially if there has been a failure somewhere.

You should be able to dump this information out to a file in the nucleus directory by running the command /nucleus info

Minecraft: 1.10.2
SpongeAPI: 5.1.0-SNAPSHOT-323db46
SpongeForge: 1.10.2-2171-5.1.0-BETA-1983
Minecraft Forge:
Nucleus Version: 0.16.2-5.0 (Git: 9a9c058)


Minecraft (Minecraft) version 1.10.2
Minecraft Coder Pack (mcp) version 9.19
Forge Mod Loader (FML) version
Minecraft Forge (Forge) version
SpongeAPI (spongeapi) version 5.1.0-SNAPSHOT-323db46
SpongeForge (sponge) version 1.10.2-2171-5.1.0-BETA-1983
Nucleus Mixins (nucleus-mixin) version 0.15.0-5.0
FlexibleLogin (flexiblelogin) version 0.8
FoxCore (foxcore) version 0.10.2-api5-204
FoxGuard (foxguard) version 0.20.2-api5-347
GriefPrevention (griefprevention) version 2.2.0
LuckPerms (luckperms) version 2.16.25
Nucleus (nucleus) version 0.16.2-5.0
Pixelmon (pixelmon) version 5.0.0-beta12
Pixel Extras (pixelextras) version 2.2.3
PoreRT (pore) version 1.0.0-SNAPSHOT
ProjectPortals (pjp) version 0.13.6
StatusProtocol (statusprotocol) version 0.3
ServerListPlus (serverlistplus) version 3.4.7
SkinsRestorer (skinsrestorer) version 1.0
TitleMOTD (tmotd) version 1.0
WorldEdit (worldedit) version 6.1.4

Plugins from PoreRT:

@curscascis @dualspiral

Fixed. I removed PoreRT from mods folder and now prefixes and chat formatting works :wink:
Thanks for all.

Woot, glad you got that fixed!

You know where is located LuckPerms permissions file?
I need to create some groups with same permissions, adding 1-2 permissions…
I can’t find it D:

so luck perms uses the h2 database by default, it’s somewhere in your server directory if you search for it.
I would suggest you just use the commands:
/lp creategroup name1
/lp creategroup name2
/lp group name1 parent set name 2
/lp group name2 parent set default
/lp group name 1 permission set true

If you are eager to use a file based method, you can change it to flatfile, and it should generate some files where you can edit permissions and groups. you will have to do /lp export filename first and then /lp import filename once you switch over to using a file based system.

:stuck_out_tongue: PoreRT overwrites the chat because reasons (I know cuz I coded that part myself, I might change it now though)
EDIT : just added a check for if any plugins actually changed it before overwriting it

Then now i can use PoreRT?

Well, you’d need to update, but yeah

1 Like

Now works.
Thanks :wink: