PL! I find a problem!


#1

Sorry,I don't know speak English.
SO,Please use Google translate.hahaha~
怪物或者NPC,在远离玩家超过大概10个方块的距离后,会停止工作
SO,I can't play the "shincolle mod" and "minecolonies mod",because they are Stop working in the server.
Who can help me???
在线等!急!hahaha~~~


#2

That sounds like you have a short entity activation range setting. It defaults to a range of 32 blocks.
Have you changed any of the entity-activation-range settings in the sponge.conf files?


#3

Yes,the monster changed 48.maybe I should change 64 for moster?


#4

Hi,friend,can I speak Chinese?My English test is so bad!


#5

You can try using Chinese, but I cannot guarantee that the translations will be acceptable. Google translate sometimes produces ... interesting results.

Try turning the entity activation range feature off in the config. file, and see if that improves performance.


#7

The entity activation range is “auto-populate=false”
Maybe you can see the config.

entity-activation-range {

If enabled, newly discovered entities will be added to this config with a default value.

auto-populate=false

Default activation ranges used for all entities unless overidden.

defaults {
ambient=32
aquatic=32
creature=32
misc=16
monster=48
}

Per-mod overrides. Refer to the minecraft default mod for example.

mods {}
}
entity-collisions {

If enabled, newly discovered entities/blocks will be added to this config with a default value.

auto-populate=false

Default max collisions used for all entities/blocks unless overidden.

defaults {
blocks=8
entities=8


#8

Actually, you can turn off the entity-activation range feature completely.
Look further up in the file, under the heading "Modules" and set entity-activation-range to false.


#9

thanks,let me try again