Plugin module dependencies in SpongeForge


#1

I’m using SpongeForge and the environment as suggested here: https://docs.spongepowered.org/stable/en-GB/plugin/debugging.html

My plugin has its own gradle dependencies which I need to be included when I run SpongeForge.

I have my plugin as a module dependency to SpongeForge, but the plugin’s dependencies aren’t being included when I run the server.

How can I have the module dependencies included when I run the SpongeForge server?


#2

Just out of curiosity, is this when running via IntelliJ?


#3

Yes, sorry. Forgot to specify.


#4

Not sure if its the same issue, but in that case you might want to take a look at this issue made for IntelliJ: https://youtrack.jetbrains.com/issue/IDEA-182304

For some reason it seems that newer versions of IntelliJ are flattening dependencies (or something strange), and it prevents nested dependencies from working right. Not sure if this is the same issue your having though.


#5

Seems like it describes my situation exactly, will keep an eye on this. Thank you!