Plugin to modify join/leave messages?

I’d like to have something like "[+] " and "[-] " when a user joins/quits.

I found SpongeMessages, but it hasn’t been updated since 2015 and the download links is broken anyway.

Any recommendations?

I’m supposed to update ChitChat soon, which ha support for this. I just need to get around to fixing the last few things that annoy me.

Cool! :slight_smile:

UltimateCore’s module called connectionmessages can do this.
It also has firstjoin messages & changename messages
Everything is configurable, and if you don’t need the other modules you can disable them easily
If you need any support, contact me on my discord (link in the thread)

It looks good. :slight_smile: But alpha? How alpha?

Should work fine and it is pretty stable, but you might find a bug from time to time.
Just report it on the UC discord and it should be fixed pretty quickly

Ah! I’ll try it then. :slight_smile: I don’t use Discord though, I’m staying true to IRC.

Ah ok. I am around on the sponge forums so if you have any problems you can always message me
I am also in the #sponge and #spongedev irc channels so you can pm me there as well

I will say that Nucleus can do this all too, and has been able to for some time, so if you’re using Nucleus, or you struggle to set it up using other plugins, that’s another way to go. If you do end up using Nucleus, tells you how to do it.


I didn’t know Nucleus could do it. I’m actually already using Nucleus, so that’s nice. Don’t know how I could have missed it in the config though. Thanks!

1 Like

Yeah, I’m trying to improve my docs at the moment to make things more discoverable.

If you need any more help, feel free to join us in Discord and just delve in with your question:

As I said in a previous comment, I don’t use Discord. :slight_smile:

I have a question actually. As the server owner I gave myself full permissions to everything (with some command I found somewhere, I can’t find it now though).

But there’s a few things I wan’t to change, like the cooldown for using the command /home. I ran the command /pm users <user> set option nucleus.home.cooldown 600, but it doesn’t work, I can still use it as often as I want to. I guess I’m doing something wrong?

1 Like

You will have the permission nucleus.home.exempt.cooldown, which bypasses this, so if you remove that permission, it should work.

Oh, and I should have registered that part about Discord, sorry!

Thanks! It works now. :slight_smile:

1 Like

My friend has 0 permissions, he can’t even use a crafting table. What’s wrong?

I don’t block the use of a crafting table at all, so I don’t know what it could be. Depending on your permission plugin, you could get it to spit out the permission checks it does when trying to use the table - you’d have to consult with the docs of your permission plugin on how to do this, though.

Ah, wasn’t sure which fault it was. :stuck_out_tongue: