ProjectInventories - Multi world inventories

Okay so I’m having the issue of “Please wait for your inventory to be loaded” I can’t even do SHIT as an admin/OP of the server. Because it doesnt even LET ME TOUCH MY INVENTORY. I did the instructions to switch and all to set it all up and wow! look here, it doesn’t work.

Hi,
same problem with “Please wait for your inventory to be loaded”
The first time i was create in mysql data base, i can access my inventory. But if I change server nothing seems synchronized with database.
If i disconnect and reconnect, i have “Please wait for your inventory to be loaded” and this is impossible to do anything.

I don’t know why but it’s seems that the mod don’t found an “old” inventory.

I try to create an inventory “test” and i can get it.
But i can’t return on default inventory : "Error occurred while executing command ‘inv get test’ for source EntityPlayerMP[‘Ysharu’/768, l=‘Hub’, x=750,50, y=86,00, z=794,50]: null

I create “test2” and i can get it
But i can’t return on test or default inventory : same error

same problem i suppose when i disconnect/reconnect :

The Scheduler tried to run the task pji-S-14 owned by Plugin{id=pji, name=ProjectInventories, version=0.12.2, description=Multi world inventories, url=http://github.com/TrenTech/ProjectInventories, authors=[TrenTech], source=./mods/projectinventories-7.2.0-0.12.2.jar}, but an error occured.

java.lang.NullPointerException: null

at java.util.Objects.requireNonNull(Objects.java:203) ~[?:1.8.0_202]

It seems that list of available inventory is always Null execpt when i create a new one. It ssems that GET function erase the list.

or the call to function getting the available inventory is missing anywhere.

What version of sponge are you using? Are you using MySQL or H2? Partial snippets of errors doesn’t tell me much. I need logs.

same problem with “Please wait for your inventory to be loaded”
forge-1.12.2-14.23.5.2838-universal
spongeforge-1.12.2-2838-7.1.7-RC3900
projectinventories-7.2.0-0.12.2

Tried both MySQL and H2, but I think I don’t know how to do the MySQL properly, so I may not have done that correctly.

Do logs like this help?
https://pastebin.com/XgkWJ2WK

Hi, I have Project core, portals and inventories on my server. For some reason when I do /inv the only subcommand that works is /inv create. This is after manually adding each perm to my user (using LuckPerms).

Any help would be appreciated

A good plugin!
But I’m having trouble with the latest version. When login game will show this “Please wait while inventory is updated!” I can’t do anything,so I must remove this plugin.Hope can fix it.

And I can’t use before version,It still show that.