Server crash due to Thaumcraft


#1

Hello, my server seemed to have worked fine without sponge. After adding sponge, it crashes. According to the crash log, I think Thaumcraft might be the source.

Is there any way I can fix it?

I’m using the latest version of spongeforge (1.12.2-2838-7.1.7-RC3848)

Server Log: https://pastebin.com/hFRxjA5F
Crash Report: https://pastebin.com/P669kkzB


Server start up crashing at Sponge.jar
Crash after adding Sponge Forge (Solved)
#2

Looking at the log, I suspect it might actually be Moving World, having a mixin conflict - it failed to load the refmap. Have you tried prefixing the SpongeForge file with _aaa to make it start first? I know that Thaumcraft normally works OK with SpongeForge, I’m using it on another server.
Also, the jar file ThermalExpansion-1.12.2-5.5.4.43-universal.jar appears to be empty.


#3

I’ve tried prefixing spongeforge to be at the top, and at the bottom of the list. The problem still persists.


#4

This appears to be an issue with the Phosphor mod.

In the log file there is this message:

Please keep in mind that Sponge support is experimental (although supported). We cannot currently detect if you are using Sponge’s async lighting feature, so please disable it if you have not already.

If not already done so, I suggest following the advice and turn of async lighting (https://docs.spongepowered.org/stable/en/server/management/performance-tweaks.html#async-lighting)


#5

Nope, the same exact crash still happens after disabling async lighting :confused:

Log: https://pastebin.com/hD6ZnDDG
Crash report: https://pastebin.com/wp9ejhSa


#6

OK, I know that sponge has had a lot of mixin changes recently, how about try a slightly older version - try the recommended SpongeForge version 1.12.2-2825-7.1.6 with Forge 14.23.5.2825

Edit: Looks like this issue is known and will be fixed soon. Backdating SpongeForge should work in the time being


#7

It seems to work now, thanks