Server keeps crashing (pixelmon reforged 1.12.2)


#1

So i made a pixelmon reforged server and everytime i run it this is what comes up:

---- Minecraft Crash Report ----

WARNING: coremods are present:
SpongeCoremod (spongeforge-1.12.2-2825-7.1.6.jar)
Contact their authors BEFORE contacting forge

// Daisy, daisy…

Time: 29/08/19 12:10
Description: Exception in server tick loop

net.minecraftforge.fml.common.LoaderExceptionModCrash: Caught exception from Pixelmon (pixelmon)
Caused by: java.lang.NoSuchMethodError: net.minecraftforge.fml.relauncher.ReflectionHelper.getPrivateValue(Ljava/lang/Class;Ljava/lang/Object;Ljava/lang/String;Ljava/lang/String;)Ljava/lang/Object;
at com.pixelmonmod.pixelmon.entities.pixelmon.EntityPixelmon.(EntityPixelmon.java:91)
at com.pixelmonmod.pixelmon.CommonProxy.registerInteractions(CommonProxy.java:220)
at com.pixelmonmod.pixelmon.Pixelmon.init(Pixelmon.java:163)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at net.minecraftforge.fml.common.FMLModContainer.handleModStateEvent(FMLModContainer.java:624)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.google.common.eventbus.Subscriber.invokeSubscriberMethod(Subscriber.java:91)
at com.google.common.eventbus.Subscriber$SynchronizedSubscriber.invokeSubscriberMethod(Subscriber.java:150)
at com.google.common.eventbus.Subscriber$1.run(Subscriber.java:76)
at com.google.common.util.concurrent.MoreExecutors$DirectExecutor.execute(MoreExecutors.java:399)
at com.google.common.eventbus.Subscriber.dispatchEvent(Subscriber.java:71)
at com.google.common.eventbus.Dispatcher$PerThreadQueuedDispatcher.dispatch(Dispatcher.java:116)
at com.google.common.eventbus.EventBus.post(EventBus.java:217)
at net.minecraftforge.fml.common.LoadController.sendEventToModContainer(LoadController.java:218)
at net.minecraftforge.fml.common.LoadController.propogateStateMessage(LoadController.java:196)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at com.google.common.eventbus.Subscriber.invokeSubscriberMethod(Subscriber.java:91)
at com.google.common.eventbus.Subscriber$SynchronizedSubscriber.invokeSubscriberMethod(Subscriber.java:150)
at com.google.common.eventbus.Subscriber$1.run(Subscriber.java:76)
at com.google.common.util.concurrent.MoreExecutors$DirectExecutor.execute(MoreExecutors.java:399)
at com.google.common.eventbus.Subscriber.dispatchEvent(Subscriber.java:71)
at com.google.common.eventbus.Dispatcher$PerThreadQueuedDispatcher.dispatch(Dispatcher.java:116)
at com.google.common.eventbus.EventBus.post(EventBus.java:217)
at net.minecraftforge.fml.common.LoadController.redirect$onPost$zza000(LoadController.java:553)
at net.minecraftforge.fml.common.LoadController.distributeStateMessage(LoadController.java:135)
at net.minecraftforge.fml.common.Loader.initializeMods(Loader.java:744)
at net.minecraftforge.fml.server.FMLServerHandler.finishServerLoading(FMLServerHandler.java:108)
at net.minecraftforge.fml.common.FMLCommonHandler.onServerStarted(FMLCommonHandler.java:338)
at net.minecraft.server.dedicated.DedicatedServer.func_71197_b(DedicatedServer.java:219)
at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:486)
at java.lang.Thread.run(Unknown Source)

A detailed walkthrough of the error, its code path and all known details is as follows:

– Head –
Thread: Server thread
Stacktrace:
at net.minecraft.server.MinecraftServer.handler$onCrashReport$zjo000(MinecraftServer.java:3980)

– Sponge PhaseTracker –
Details:
Phase Stack: [Empty stack]
Stacktrace:
at net.minecraft.server.MinecraftServer.handler$onCrashReport$zjo000(MinecraftServer.java:3980)
at net.minecraft.server.MinecraftServer.func_71230_b(MinecraftServer.java:889)
at net.minecraft.server.dedicated.DedicatedServer.func_71230_b(DedicatedServer.java:371)
at net.minecraft.server.MinecraftServer.run(MinecraftServer.java:558)
at java.lang.Thread.run(Unknown Source)

– System Details –
Details:
Minecraft Version: 1.12.2
Operating System: Windows 10 (amd64) version 10.0
Java Version: 1.8.0_221, Oracle Corporation
Java VM Version: Java HotSpot™ 64-Bit Server VM (mixed mode), Oracle Corporation
Memory: 793641376 bytes (756 MB) / 1502609408 bytes (1433 MB) up to 1908932608 bytes (1820 MB)
JVM Flags: 2 total; -Xms1G -Xmx2G
IntCache: cache: 0, tcache: 0, allocated: 0, tallocated: 0
FML: MCP 9.42 Powered by Forge 14.23.5.2768 8 mods loaded, 8 mods active
States: ‘U’ = Unloaded ‘L’ = Loaded ‘C’ = Constructed ‘H’ = Pre-initialized ‘I’ = Initialized ‘J’ = Post-initialized ‘A’ = Available ‘D’ = Disabled ‘E’ = Errored

| State | ID          | Version           | Source                                  | Signature                                |
|:----- |:----------- |:----------------- |:--------------------------------------- |:---------------------------------------- |
| UCHI  | minecraft   | 1.12.2            | minecraft.jar                           | None                                     |
| UCHI  | mcp         | 9.42              | minecraft.jar                           | None                                     |
| UCHI  | FML         | 8.0.99.99         | forge-1.12.2-14.23.5.2768-universal.jar | e3c3d50c7c986df74c645c0ac54639741c90a557 |
| UCHI  | forge       | 14.23.5.2768      | forge-1.12.2-14.23.5.2768-universal.jar | e3c3d50c7c986df74c645c0ac54639741c90a557 |
| UCHI  | spongeapi   | 7.1.0-fb496dbf0   | spongeforge-1.12.2-2825-7.1.6.jar       | None                                     |
| UCHI  | sponge      | 1.12.2-7.1.6      | spongeforge-1.12.2-2825-7.1.6.jar       | None                                     |
| UCHI  | spongeforge | 1.12.2-2825-7.1.6 | spongeforge-1.12.2-2825-7.1.6.jar       | None                                     |
| UCHEE | pixelmon    | 7.0.7             | Pixelmon-1.12.2-7.0.7-universal.jar     | None                                     |

Loaded coremods (and transformers): 

SpongeCoremod (spongeforge-1.12.2-2825-7.1.6.jar)
org.spongepowered.common.launch.transformer.SpongeSuperclassTransformer
Profiler Position: N/A (disabled)
Is Modded: Definitely; Server brand changed to ‘fml,forge,sponge’
Type: Dedicated Server (map_server.txt)

anyone know what i need to do to fix the issue?


#2

Report to Pixelmon, doesn’t look like a Sponge issue. :slight_smile:


#3

Please read this before reporting bugs (tells you how )

As for that issue. A quick read on the title of the exception is a common issue if your forge version is newer/older then what the mod requires.