Server map corrupted?


#1

i have made a server on sponge 7.1.0 which works fine sometimes, i tried to start my server today and it just keep giving me the same error i had before which i fixed by using a other map i was wondering if there is a other fix then replacing the map.
pastebin: https://pastebin.com/55cU0LXZ


#2

It looks like your level_sponge.dat file was corrupted. Usually, if you have a backup, you can restore the level_sponge.dat file from the backup and everything will work just fine.


#3

unfortunally i don’t have a backup due to the fact the this map wasn’t even over 24hours old, i do have seen some post where it was fixed by renaming ‘level_sponge.dat_old’ to ‘level_sponge.dat’’ but that doesn’t work.
is ther ealso a way to see how/why it got corrupted?


#4

Well the first check, are you using a control panel or self hosting? Did you kill the server to stop it, or user the stop command and wait for it to finish?


#5

i host it myself on my pc and if i close the server is use the /stop command and wait till its fully closed.
as for the ‘corrupted’ file i just deleted the level_sponge.dat file and for some reason the server works fine again without any lost items or such


#6

Well, there wouldn’t be any lost items, 'cause the file doesn’t store those. It just stores some Sponge-specific settings like per-world difficulty, portal agent, dimension ID, and the world UUID.