Server Will Not Start After Putting SpongeForge in Mods Folder

Hi everyone,

I’m Vigilius, and I’m new to Sponge. I was wondering if anyone could help me out with an issue I’m experiencing. I’m trying to install SpongeForge onto my FTB All The Mods server. With a fresh copy of All The Mods pack installed, the server starts up just fine. However, the problem arises when I put the SpongeForge file in my mods folder. The server simply will not start. I’ve deleted all my server files 3 times now in hopes of finding a fix.

I’ve attached a log of my console:

I believe that is the correct log needed to resolve the problem, if not, tell me and I’ll try and get a different log. (If I need a different log, please be specific on where to get said log)

Additional details:
I’ve tried version: 1.10.2-2202-5.1.0-BETA-2099 (Most recent)
And I’ve tried version: 1.10.2-2202-5.1.0-BETA-2078 (Recommended)
Pack I’m running: FTB All The Mods v1.58

Please help me resolve this a soon as possible as me and my friends want to play together on a server with plugins. :stuck_out_tongue:

Thank you,
Samuel Johnson (Vigilius)

P.S. I’ve contacted my server host (CreeperHost) about this issue, after some back and forth tickets, they said I should get support from Sponge directly. So, here I am! :slight_smile:

Unforunately, AE2 is currently incompatible with Sponge. There’s a compatible fork here: GitHub - Stonebound/Applied-Energistics-2: A Minecraft Mod about Matter, Energy and using them to conquer the world..


Thanks for the response.
I know how a couple of questions about the patch for applied energistics.

  1. Which download do I need?
    Alpha 7, 8, 9, or 11?

  2. How exactly do I install the patch? Do I just drop the applied energistics patch into my mods folder? Do I need to delete something when I install the patch?

Thank you so much for you help!! :slight_smile:

I would download Alpha 11, which is the latest released build. You should be able to simply replace the normal AE2 jar with the modified one - everything should be the same (except for the fact that Sponge will be able to start, of course :smile:).

Alternatively, you could try using SpongeBootstrap. While it’s not officially supported, it eliminates the need to use a modified version of AE2.

Foam fix is also incompatible btw I’d consider removing it.

The latest version of Foamfix (both anarchy and lawful) is fully compatible with Sponge.

Wasn’t aware thanks .

i have the AE2 alpha 11 version and im still getting that crash, ive removed foamfix and it hasn’t fixed it, if i remove AE2 it will launch regularly