[Solved] Error trying to run sponge

I’m having trouble starting up sponge in intellij. I had this working last night with one of my plugins but after I needed refresh my dependencies because something in sponge wasn’t updated the server won’t start. my client runs fine however, and from the error it gives me it doesn’t look like something on my end? I’ve tried wiping the server clean just in case and of course it didn’t help. Here is the error I’m receiving: https://ghostbin.com/paste/9c75n
I’ve searched all over this forum to see if anyone else has this issue but couldn’t find anything. Also, sorry if this is the wrong section.

Sponge is fairly unstable at the moment, I would attribute the problem to that. There may be something more to your error but I would just continue pulling from the repo, building and trying to run it until it is somewhat stable again.


Yeah, The build is still failing on my CI server cause of dependencies.

Would make sense, the surface of the stack trace says its a class cast exception, and it appears to be living inside Forge stuffs; I didn’t see any Sponge packages in there.

Nothing wrong with Sponge from what I can see.
Looks like your ForgeGradle launch is messed up.
What does your launch configuration look like? How have you setup your workspace?

Try re-running gradle setupDecompWorkspace

Here’s the exact line of code where the error is coming from:

1 Like

Me? I got it working after doing a gradle setupCIworkspace

@AbrarSyed knows about this problem, he’s attempting to fix it.

sponge version 1.0 is only for plugin dev

no, you can develop now, The SpongeAPI 1 is out, but not Sponge implantation 1

oh k the doctors life

I see that he seems to have fixed it, but I’m still running into the same problem when I run. How do I get intellij to update the dependency?

You’ll need to manually run with --refresh-dependencies

Thanks for the help. Problem Solved.