[Solved] Gradle error with dependencies

Whe I try to clone Sponge using the instructions on github (readme.md) an error occurs.
The error occurs when I execute the command

gradlew.bat setupDecompWorkspace --refresh-dependencies

and the error says

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':recompMinecraft'.
>Compilation failed; see the compiler error output for details.


Here is the full stacktrace that is printed when using --stacktrace flag.

EDIT: Here is the full log of the command specified (without the --stacktrace flag).

Same problem… ¿where is the “position” variable in class Explosion.java

Impossible verify files with setupDecompWorkspace


Patching failed: net/minecraft/world/Explosion.java Cannot find hunk target

Are we sure that the repository is cloned properly? Have you tried deleting the folder and restarting?

I restarted the whole thing 3 times. Not my problem.

I’ll test this myself, locally. Standby.

I think @blood broke something. If so, hopefullly it’ll get fixed soon.

I have to agree with @simon816. On an entirely clean local test, this is reproducible.

The day when I start to help… and it’s time to standby… hahaha don’t worry !

Tomorrow is another day. :grin:

@blood has fixed it now

1 Like


Thanks guys! :cry:

Well that was simple xD
Thank you very much.