[SOLVED] Installation Problem

Hello out there

first of all: I’m from Germany.
So if there is anybody eho can help me on german, it would be very good, if not, talk english. I can read it^^

Heres my problem, every time I tried to install Sponge to my Forge Server, the server dosn’t start. I don’t know wehere the problem is, I tried different Forgeversions an different Spongeversions, nothing helped.
I got a Server at a Hoster, it is gamed!de.
On the Server is the Forge-Version forge-1.8- and minecraft_server.1.8
I tried Spongeversion sponge-1.8-1446-2.1DEV-515 now and sponge-1.8-1499-2.1DEV-643 an sponge-1.8-1499-2.1DEV-643-release before.
Nothing worked.
I need Sponge for Pore zu plug in some BukkitMods.

Can anyone help me please?

try sponge-1.8-1499-2.1DEV-643 without (!) release
just download via main button.


Versuch mal bitte nicht die release version sondern den ganz normalen main download. Die Release Version ist quasi nutzlos für dich und wird demnächst entfernt (die sollte eh niemals dort sein :stuck_out_tongue: ).

Sponge 643 und Foge 1499 sollten problemlos laufen.

First of all, thank you for your reply.
I tried what you say but it still not works.
I also updated Forge now to Version forge-1.8- but the Server dont start, without sponge-1.8-1499-2.1DEV-643 it starts and run without any issues.

you need to use Forge version for it to work!

Sponge may be not always fit for the latest Forge version. Take a look at our docs to find out how to choose the matching Forge version.

Sponge ist nicht immer gegen die aktuelle Forge version entwickelt. Wirf mal einen blick in die Dokumentation, da steht, wie man die passende Forge Version erkennt.

How do you start your server?
If you start it locally via doubleclicking the forge.jar, then beware: Sponge disables the standard MCserver GUI! Use the commandline instead :wink:

Could you describe what exactly you are doing to get it to run?
And where you try to run it (locally or on your above mentioned server)


Ich würde erstmal versuchen das ganze lokal aufzusetzen. Lad dir erstmal die aktuellste Sponge Version (main, nicht release :wink: ) und Forge 1499 runter. Dann Forge aufsetzen und Sponge in den mods Ordner. Das sollte so laufen!

Wenn das läuft kannst du alles auf den server kopieren und dort starten (FTP Zugang/file upload solltest du dafür schon haben…).

1 Like

After my last Reply I’ve seen that the Version on my Server wasn’t updated, it can’t be manually updated an is still Version
So I tried to start the Server local, but I’m too long out of date there and i can’t start any server local, so I give up there.

Is there any Version from Spronge that is compatible to forge- sponge-1.8-1446-2.1DEV-515 does not work before

Now I get it with the local server, at the local server the it works with sponge, so its from now on a problem with my hoster. Because the only thing, why it didn’t work at the public server is because I can’t update the forge.jar

1 Like

Got another problem jet.
On my local server it works, now I updated my public server an without sponge it works, but with sponge it will not start.

Is your public server running java 8? Im not shure but i thought that sponge needs Java 8 to run ^^

Läuft dein Server auf Java 8? Nich alle Serveranbieter haben das standartmäßig drin, und meines Wissens braucht Sponge seit kurzem Java 8 um zu laufen :slight_smile:

Nope, J8 isn’t required by Sponge itself atm. But there are plugins which require J7 or J8.
However Sponge will make the transition to J8 shortly :wink:

Noch braucht man kein Java8, außer Plugins benötigen es. Sponge wird aber bald auf Java 8 umstellen, sobald Mojang das auch tut (der OSX Launcher bringt sein eigenes Java 8 mit).

1 Like