[SOLVED] Maven 403 Error

I have been developing for the 2.0 version of Sponge, but am now moving to the 2.1-SNAPSHOT. I got a 403 error when refreshing dependencies after changing over, specifically when connecting to https://libraries.minecraft.net/com/flowpowered/flow-noise/1.0.1-SNAPSHOT/maven-metadata.xml. The operation that this error is appearing on is ‘compile “org.spongepowered:spongeapi:2.1-SNAPSHOT”’.

Make sure it looks similar to one of these: https://docs.spongepowered.org/en/plugin/basics/workspace/dependencies.html

It is a gradle.build which has everything outlined there as well as some other dependencies.

gradle setupDecompWorkspace

That fixed the initial error. What gradle command should I use to export the plugin’s jar file?

gradle build

Jar is in ./build/libs/

Running gradle build results in the same error as in my initial post, even after running setupDecompWorkspace.

I can create a working .jar by exporting from the project as a temporary work around but would still like to fix gradle build if possible.

I actually had the same problem tow days ago when i was trying something with A Forge Mod + SpongeAPI. But i’m terrible in gradle stuff, so i can’t be shure it wasn’t my fault :smiley:
Ps. It was the exact same error wih the exact same dependency ^^

I found this: Temporarily use the latest flow-noise version · SpongePowered/SpongeAPI@d7f289b · GitHub
Could that be something? :o

1 Like

Yes, that resolved my issue. For anyone with a similar issue just add

maven {
name = ‘sonatype-nexus’
url = ‘https://oss.sonatype.org/content/groups/public/

to your repositories and compile ‘com.flowpowered:flow-noise:1.0.1-SNAPSHOT’ to your dependencies.