[SOLVED] Problems when starting spongeforge on StoneBlock Modpack


#1

Hi, hi got some problems using spongeforge on StoneBlock modpack, i already checked the version of Forge and Sponge Forge and all seems good but when i start up the server spongeforge won’t start creating the config folder with this error: https://pastebin.com/wcLErr5E

thank you for your help!


#2

Will the server start without Sponge installed?
It looks like this might be an incompatibility of a different mod…

Can you also please upload your entire log?
And also, what version of forge and sponge are you using?


#3

Hi, thank you for answer, i’m using spongeforge-1.12.2-2768-7.1.5-RC3506 with forge-1.12.2-14.23.5.2768-universal, here is the full log on pastebin=

https://ufile.io/roj6v (i had to upload it cause is bigger than 512kb for pastebin)
Virus Total —>https://www.virustotal.com/#/url/2fe6d938bf13b06acfbc89975827ad1f4b7e2fe74cdba8445e08a3082bcdd910/detection

i tried everything, if i remove all mods spongeforge works really good, with the mods if i put spongeforge the server works well but doesn’t create the spongeforge config folder.


#4

I’m currently trying the same. I personally think it is some chunk loading issue since i remember the error contained something about AnvilChunkLoader. Running the server without sponge works fine. Except i had a small fml issue that warned me about sponge:human after the first startwithout sponge again.

I will drop my error log tomorrow.

I’m using the most recent recommended build of sponge forge and the version of forge that comes with stoneblock.


#5

I also encountered this problem.
https://forums.spongepowered.org/t/my-server-can-not-start-without-crashreport/26089/2


#6

I tried this too, but here is the crash report:
Report

I’m using forge-1.12.2-14.23.5.2768
and sponge 1.12.2-2768-7.1.4.
So i guess i use the right version?


#7

Both SpongeForge and FoamFix add various optimizations that may not work with each other! Disable the following settings in the config/foamfix.cfg B:optimizedBlockPos=false (Sponge adds a similar performance patch) B:patchChunkSerialization=false https://github.com/asiekierka/FoamFix/issues/166


#8

Thank you for your help, that worked to fix the sponge loading error but now i got another problem, as you can see here on the log, the server crashes at the end and i don’t know why.
https://uploadfiles.io/49l7s (Can’t upload it on pastebin cause is bigger than 512 kb)

and here is the
virus total link ---->
https://www.virustotal.com/#/url/4ac3a76109cc09a3c9c779ac50eb6b1643f7d73754ba80d202a8849aa593f692/detection.


#9

SOLVED – just removed PermissionsEx and everything worked, Thank you so much.


#10

Thanks for the solution :slight_smile:


#11

Thank you all I was looking for a solution to this problem


#12

updated to the new version now does not work again I can load the full server build if needed