[SOLVED]Unable to connect to spongepowered.org

I’m unable to connect to any of the sponge related sites through HTTPS. This problem started when SSL was added. When I connect to the HTTP site it’ll redirect me to the HTTPS site which can’t be loaded. I’m able to ping the site just fine:

Pinging forums.spongepowered.org [] with 32 bytes of data: Reply from bytes=32 time=14ms TTL=55 Reply from bytes=32 time=14ms TTL=55 Reply from bytes=32 time=14ms TTL=55 Reply from bytes=32 time=14ms TTL=55
Directly entering this IP in my browser will result showing a cloudflare direct IP access error, so that’s not the issue. I have brought this briefly up in the IRC where I was told to contact CloudFlare and my ISP. I contacted both CloudFlare and my ISP and they told me there were no issues at their ends and that I should contact the site administrator about the issue I’m having. I can connect fine through TOR or any other VPN. Any ideas? I have tried different browsers, different devices, all result in the same issue.

your isp is lying to you then, if TOR works as well as other VPNs then that means it can’t be a cloudflare or sponge error.

1 Like

You living in China by chance because Doc is right. Your ISP has probably blocked a site on the same server as SpongePowered (assuming SpongePowered isn’t on a dedicated server) or they just don’t like sponges…

I live in Belgium, and I can connect to the site on port 80 just fine, so it would really suprise me if they’re blocking it. It’s just port 443 (HTTPS) not responding my requests.

Can you access google of port 443 or https? and if so ask your ISP if they are blocking https://spongepowered.org, if not ask your ISP to unblock 443

An ISP would not block 443, since that would make no sense. Not saying that American ISPs make sense, but it’s possibly a firewall issue.

Disclaimer: I’m guessing.

Looks like it, I tried connecting on my iPhone through WiFi and it’s working there. I tried disabling my firewall but that didn’t solve anything. Any ideas?

Possibly a virus that blocks 443? I don’t know if that’s possible or even exists but maybe.

Disclaimer: complete shot in the dark.

Probably not. A virus that port forwards 443 would make sense – no real use on blocking it.

@Ivan, what OS, router, and modem are you using?

Windows 7, Netgear WNR 2000 running with OpenWRT and my modem is branded by my ISP so I’d have to figure out which model they’re using. I can access all firewalls on there, and nothing in there looks out of order.

EDIT: using BitDefender as my firewall, but I’ve tried to turn that off.

One thing we haven’t tried. What browser are you using? Some browsers (like Chrome) block sites if they appear suspicious.

What happens if you try another browser? Google chrome is know to almost cache everything… .

@Pink__Slime @thomas15v
I’ve tried Chrome and Internet Explorer.

Try Opera. It’s the second best “main” browser.

Another option it could be, is that a proxy script (installed trough share/mal ware) is blocking https.

I’m able to connect to HTTPS sites, it’s just the ones provided for free by cloudflare aren’t working.

Yay! Managed to fix it! Seems like it was BitDefender’s SSL Scan feature that was blocking the site because there was something wrong with the certificate. Thanks to everyone who helped out!

I’d suggest removing it all together. Most internet security tools are useless now as browsers do fine on their own. Plus if you’re paying $100 for it, you’re an idiot (no offense).

Yeah, my security is composed of malwarebtyes and that is pretty much all.

Yup, malwarebytes and microsoft defender are all you really need anymore. I also use a tool by a French development team that does a great job on malware and adware. And another tool called JRT (Junkware Removal Tool).

Adware Cleaner:


1 Like